Devterm CM4 printer prints nothing but "bar codes"

Hi all. I finally got some paper for my devterm printer. Unfortunately, all it prints is the exact pattern of bars no matter what I try to print. I eventually tried

sudo apt install -y devterm-thermal-printer

after reading a forum post. This actually caused the printer to completely stop working and disabled the networking as well. I reimaged last time because I could not figure out why wifi stopped working and nothing seemed to fix it. This time I immediately tried:

sudo apt remove -y devterm-thermal-printer
sudo reboot

Network support came right back up. Now the printer can’t even print the bar code errors anymore. It does nothing at all because the driver is gone. I decided I don’t know what I am doing and I don’t even know if the printer is DOA out of the box. Sucks because this is one of the most fun things about this device.

I tried this command too when the printer made noises and spat out bar code:

echo -en “\x12\x54” > /tmp/DEVTERM_PRINTER_IN

it spat out more bar code…just about a two inch long bar code of the exact same pattern as the thing does of I print “test” in text editor or geany. Same pattern, just shorter. I am using vonylist 58mm thermal paper as advertised it would print with.

Anyone have a clue what the issue might be?