Devterm printer kernelspace driver

9 Likes

Ink is running out.

Grayscale print

4 Likes

Amazing print! I have to try it one of these days when I solve the pigment deposition issue.

hitherdither library

3 Likes

Can you explain what’s this?

It’s kernelspace driver which you use instead of devterm-printer.service
no CUPS yet.
See prepare (No devterm linux headers package) and install files.
see py scripts for userspace interface.

As burn parameters are exposed via ioctl it is possible to do grayscale image.

5 Likes


For me effect which I wanted is realised.

BTW: Font borrowed from 24-pin matrix - here python scripts to export/render this font in python GitHub - korneliuszo/png2escp

1 Like


Done cups driver

4 Likes

This looks very cool, to install the cups driver do I need to follow the previous prepare and install instructions or just follow the cups install?

Yes you need to install driver.
You can copy .ko file to /lib/modules/${uname -r}/ and do depmod for auto loading module

new here, i’m trying to install this driver but i’m having problems to compile it.

appears an error if i try to compile… any tips or help please??

It’s probably problem which occured for me too.
Linux kernel changed revision in armbian but devterm team didn’t update its linux build.
Try installing https://mirrors.dotsrc.org/armbian-apt/pool/main/l/linux-5.10.60-rockchip64/linux-headers-current-rockchip64_21.08.1_arm64.deb

1 Like

thanks a lot for the reply, solved my problem when i compile the driver :smiley: but i think i’m making some mistakes when i try to make it autoload or similar :frowning_face:
i tried insmod, modprobe, copy the .ko file on the modules directory, etc… but the driver didn’t load automatically on booting the system :cry:
how i can proceed for install the driver correctly (surely i’m wrong on some step when i try to install it)

another detail i found when i try the github codes it’s on the python scripts… keep appearing an error like this and make impossible to use it… any help??

OSError: [Errno 25] Inappropiate ioctl for device

this error appear on mtp02_ioctl.py :: get_settings (looks like on the code the device is ‘iiii’ or maybe this is a problem related to driver installation…)

sorry for keep disturbing with these questions, and thanks a lot for any help :smiley:

I’ve put .ko into
/lib/modules/5.10.60-rockchip64/mtp02/mtp02.ko
and then run depmod, and it loads at start of system.

For ioctl I think you made file called /dev/mtp02.0 which souldn’t be made - it’s udev role to create it.

(sorry was quite busy last days…)
hope all of you had an awesome christmas :smiley:

back to topic, i tried the depmod and keeps without being automatically loaded…
i found this error into “/var/log/kern.log” file:

mtp02: loading out-of-tree module taints kernel.
mtp02: module verification failed: signature and/or required key missing - tainting kernel.

looks like exists some kind of error when the kernel load the module… and i tried to apply on the “Makefile” the line “CONFIG_MODULE_SIG=n” to bypass this check but looks like keeps having the same problem…

maybe you’re using other type of OS image or similar? (autocompiled or something?)

related to the /dev/ file, i checked and it’s automatically created, for this part looks like nothing wrong but keeps throwing the same problem when try to use the python codes.

Thanks a lot for any help :smiley:

taint kernel is normal.

creating /dev/ means dtbo is applied correctly

2021-12-21 - I’ve changed ioctl structure - you need have module/python code in sync.

bwprint.py should work without problems.

can you strace ./grayprint.py ?

Made aur packages for tools from repo:

Needs image 20220117 or updated u-boot.
For running dkms you need to install linux-clockworkpi-a06-headers manually.
Also you need to append /boot/extlinux/extlinux.conf
with line

FDTOVERLAYS /overlays/mtp02-a06-devterm.dtbo
3 Likes

Apologies, the forum wouldn’t let me post again in the manjaro-linux-support topic. But here is the print-to-file you requested. Thanks again for your help!

output.pdf

Fixed in new version of driver.

Update package from aur and modify printer in cups to reload ppd file