Brilliant device but a couple of problems

Hi just to say the DevTerm arrived for me and it is great!

I just wondered if anyone can help with a few issues I’m having?

By default the username and password is cpi

So I changed my username and password using usermod.

I don’t know if it is related but when I now download files to my home folder they seem to be corrupt (not sure if permissions or groups are messed up etc).

The same files downloaded on my other Linux box are fine, but on the DevTerm they won’t open…

My other issue seems to be with the printer. It does print, but the printout has a lot of lines running through it and seems to also get a bit scratched by the rip teeth too. It also sounds like the cog is struggling a bit. Is this a common problem? The print lines seem odd, I can take it all apart to try re-fit things if you think it might be how I’ve put it together that
is the cause… but everything seems to be located OK.

Lastly, again with the printer: How do you add it fresh in printer settings? What is the URI etc?

Other than these teething problems the DevTerm is ace!! Thanks

1 Like

The lines problem come from wax deposit onto the head from the paper, I have the same issue and tried with paper from two stores, now I have 20 rolls :stuck_out_tongue:

If you clean with a cotton swam and isopropyl alcohol those black dots its fine until they get built up again.

Thank you, I’ll try cleaning as you suggest.

Cleaning with lots of 90% alcohol has fixed the dots/lines problem.

Any ideas how I now add the printer back to my system in Cups so I can print from the browser or Abiword etc to the Thermal?


What do you mean with “back to my system”? The usual print funtion of the browsers or GUI apps works by default.

Also there is a user of the forums that ported the print service to a kernel space driver you could check that too

When I remove the printer and then click to add it again in ubuntu I’m not sure what the URI is or port etc to add it back and get it working in CUPS.

Any help appreciated :slight_smile:

/usr/sbin/lpadmin -p devterm_printer -E -v “serial:/tmp/DEVTERM_PRINTER_IN?baud=115200+bits=8+parity=none+flow=none” -P /usr/share/cups/model/clockworkpi/cpi58.ppd

1 Like

This worked great, thank you!