DOSBox on the A-06 uConsole

Hello there. I have a A-06 uConsole, but I’m struggling with getting DOSBox to work properly in full screen. I’m able run both DOSBox and DOSBox-Staging, but they seem to suffer from different issues. DOSBox runs in full screen, but the screen cuts in half unless I reboot my uConsole. DOSBox-Staging doesn’t have this issue, but it has performance issues and lags. I tried editing the configs, but unable to get things to work properly.

Were you able to get DOSBox to run properly on your A-06 uConsole and if you did, which version did you use, and what settings did you use? Thanks for your time.

1 Like

I dunno specifically about the a-06 but I know some graphics cards have a problem with full screen resolution refresh rate… or graphics engine… on my walmart tablet i had to switch “output=” from “surface” to “opengl” run through those if your screen is missing parts…

Also if you don’t have the settings for refresh rate set to ~native, some of the resolutions have Hz settings that jack up your screen… and that could get stuck till you reboot…

hope that helps you!

DOSBox worked fine for me, but maybe because I’m using ratpoison rather than the full Xfce environment.

screen cuts in half unless I reboot my uConsole

This is an issue that DOSBox has even on my desktop system. Basically, in full-screen mode, instead of using its own scaling method, it adjusts the X resolution. Huge pain, especially in dual-screen setups.