clockworkpi

Game Shell freezeing

Hey I just flashed to the version three of the OS and when I play a mgba,MAME,or NES game and press start button the screen on the gameshell freezes but I can still use the controls and navigate but the picture stays the same until I turn it off. I have looked at my retroarch settings and don’t have start(Enter) set to anything else but start. On the other hand when I play prince of Persia, cave story, or Open Tyrian there no freezing. Does anyone know how to fix this or if it’s just an OS version three glitch. Any info or help is appreciated.

I’ve seen similar issue.

You have, can you point me to where I can find where they talk about this and how to fix it please. I have read comments from different topics but haven’t really found something to help and going through all these topics is gonna take some time. So if you can point me In the right direction it would really help.

1 Like

Any news on this issue?

Same thing here. It’s not happening with PSX or PICO-8 though, but I’m having the exact same error with NES, GBA (both gPSP and mgba) and MAME

I’m running retroarch 1.7.7 and I’ve tried also different cores from different sources. Weird :frowning:

The same thing is happening to me, I have version 1.7.7 of Retroarch.
On the other hand, it also happens with the games of Prince of Persia and Cave Story, the image remains frozen.

Did you guys try removing the retroarch.cfg file and see if it works? It’s probably some setting messing it up. Try with the default configuration and if it works, start changing back the settings you want, one by one, until you figure out what is the problem.

Thanks for your reply!

I did try to do that, but still happens. I use @hpcodecraft 's script to update Retroarch.

Same problem here.
The truth is that version 0.3 is a complete disaster and I’ve been waiting for months for a system update that allows playing perfectly with RetroArch emulators with activated Lima.
They are spending all their efforts to achieve marketing this machine in different stores like Amazon, but leave their users completely disconnected with a disastrous firmware, full of bugs and failures.

And does it happen with “stock” system? I mean, testing it after writing the clockworkPi 0.3 image file and not change any preference, to see if it works in that case. If it doesn’t, it is really a hardware problem and you should contact support.

Thanks for you help, @bitdweller

Honestly I have made tons of changes, so I suppose I need to format my card and write the image file again to check if a new install works fine.

It has to be something related to retroarch though, as PSX and Pico-8 work fine (and they are both standalone installs). I already tried to remove retroarch.cfg in the .config folder and update retroarch.

That has happened to me has well, changing lots and breaking stuff.

Lately I’m more peaceful as I only want to enjoy the games now (currently on Link’s Awakening) :slight_smile:

¡Suerte!

Just an update from my side (it might be useful if you are having this same issue):

  • I have formatted my card and write the newest image file again
  • I’ve used @hpcodecraft 's script to expand my partition to 128Gb and update Retroarch
  • The bug keeps happening.
  • So I’ve formatted the card again
  • I use the script to expand my card but didn’t update Retroarch
  • Everything works fine now

I’m not saying that there’s something wrong with the script (obviously), but it might be something related with RetroArch latest version and Gameshell OS v0.3 ¿?

I confirm everything said by @kekoponte.
I returned to burn the image and did not update Retroarch, I have it in v 1.7.5 that came in the image (v0.3) and everything works well with Lima.
I understand then that it is a problem of image compatibility v 0.3 OS and Retroarch 1.7.7

Retroarch 1.7.7 had a bug which was fixed https://github.com/libretro/RetroArch/issues/8720

Maybe you can explain how to use/apply this fix? Or it was fixed permanently and we just need to redo install process of version 1.7.7 and it will apply automatically?

They merged the latest pull request so a git clone or if you already have it, a git pull

After “make -j4” command at the end I’m having:

obj-unix/release/gfx/video_driver.o: In function video_context_driver_find_prev_driver': video_driver.c:(.text+0x3918): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o: In function video_context_driver_find_next_driver': video_driver.c:(.text+0x39cc): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o: In function video_context_driver_init_first': video_driver.c:(.text+0x3ad4): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o:(.data.rel.ro+0x10): undefined reference to `gfx_ctx_mali_fbdev’
collect2: error: ld returned 1 exit status
Makefile:197: recipe for target ‘retroarch’ failed
make: *** [retroarch] Error 1

Any idea?

How did you configure it?

I used:

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --disable-discord --disable-langextra --enable-mali_fbdev --enable-opengles --disable-opengl_core --disable-opengl1 --disable-qt

Edit:

also do

sudo apt-get install git build-essential
sudo apt-get build-dep retroarch

before compiling

I made it.
I made:
sudo apt-get install git build-essential

sudo apt-get build-dep retroarch

git clone https://github.com/libretro/RetroArch.git retroarch

cd retroarch

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --disable-discord --disable-langextra --enable-mali_fbdev --enable-opengles --disable-opengl_core --disable-opengl1 --disable-qt

make -j4

And then it happens as I described:
“LD retroarch
obj-unix/release/gfx/video_driver.o: In function video_context_driver_find_prev_driver': video_driver.c:(.text+0x3918): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o: In function video_context_driver_find_next_driver': video_driver.c:(.text+0x39cc): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o: In function video_context_driver_init_first': video_driver.c:(.text+0x3ad4): undefined reference togfx_ctx_mali_fbdev’
obj-unix/release/gfx/video_driver.o:(.data.rel.ro+0x10): undefined reference to `gfx_ctx_mali_fbdev’
collect2: error: ld returned 1 exit status
Makefile:197: recipe for target ‘retroarch’ failed
make: *** [retroarch] Error 1”

Also, there are some red text, maybe it is important?: “menu/menu_setting.c:2373:13: warning: ‘config_bind’ defined but not used [-Wunused-function]
static void config_bind(
^~~~~~~~~~~
menu/menu_setting.c:2349:13: warning: ‘config_hex’ defined but not used [-Wunused-function]
static void config_hex(
^~~~~~~~~~”

Maybe it is because I already updated previously to 1.7.6 using “bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/gameshell-setup/master/run.sh)”?