clockworkpi

Retroarch: Audio but no picture

Hi, all. I just got my GameShell in the mail today as my inaugural Father’s Day gift, and I think it’s pretty cool… Except I’m having trouble actually playing any retro games on it.

I’m a total layman when it comes to most Linux and/or code stuff, so apologies if the answer to this is super simple. My most recent experience has been with a RetroPi.

I had no trouble configuring RetroArch on the GameShell (including adding my RetroAchievements login info to the config file), moving my games onto the SD card or downloading cores. However, any time I load up a game I can hear it boot and up and start running, but I can’t actually see anything – the screen is just pure white or pure black, depending on the system. I’ve tried multiple cores across multiple systems, and they all have the same problem.

Weirdly, if I try playing an original GameBoy game, the white of the screen I’m shown is Game Boy proportioned, but I still don’t actually see the game.

I tried adhering to the RetroArch MegaThread’s setting suggestions for drivers, video and audio, but it didn’t seem to make any difference.

I’m on stable 1.24 with an up-to-date launcher (I guess?). Any suggestions on what the issue might be?

if it’s ok
you can record a video ?

:slight_smile:

Sure. It’s not very interesting, but it shows what I’m talking about.

(I took a few seconds to scroll through ROMs to get to one I knew had sound right at bootup.)

Another thing to note: When I hit the menu button, the sound stops as if I’ve pause the game and opened up the RetroArch menu… but the screen is still blank. I showed that in the video, too. I have to power down the device just to get back to a usable state.

In further testing I got maybe a single frame of a GBA game to appear at boot, but then the image just froze on that frame. It’s as if the video driver is crashing but everything else is working normally.

If you’re on OS 0.3 I think this is the expected behavior? I haven’t been able to use Retroarch (or the built in emulated systems from the launcher which use the same) since I updated. Some other standalone emulators work, as does most homebrew games and apps, Pico-8 and Tic-80, etc.

If there’s a way to actually get Retroarch running properly under the current OS, I’d love to know too! The performance and battery life is way better and I enjoy Pico-8, but my GameShell hasn’t been emulation focused for quite some time. I’ve been hoping for an OS update to fix the display driver issue but it seems to be a very long time in coming.

Dumb question, but how would I know if I’m running 0.3 or not? The only version number I can find anywhere is “Stable 1.24.” I haven’t done any code/Github based updates, because frankly that’s outside my comfort zone right this second.

If the emulation stuff is just broken, I would hope it gets fixed soon. It was practically the only reason I bought the GameShell in the first place.

Edit: If I’m on 0.3 and that’s just a no-go for emulation, can I just flash the SD with an older OS and get things working that way?

Not a dumb question at all! The launcher doesn’t make it easy to figure out which OS version you’re running, unfortunately. But I think this post might help:

On the Settings->About screen, near the bottom it will show the Kernel version. There’s more related information in that thread.

I guess I misspoke that Retroarch never works and always has a black screen, it’s just that it happens so frequently, I gave up on it in OS 3. When and if it does work (and doesn’t later lock up), it runs great with no screen tearing. I’ve seen reports on the forums about OS 2.1 having screen tearing issues, although it does seem to consistently work. The OS itself has battery drain issues though and sounds like it runs the device hotter than it should.

I got my device mainly as a “real” device for Pico-8, and to tinker around with porting other games, etc. The emulation was a big draw too, but I’ve kind of learned to live without it (still sad about that though), because the current OS runs everything else so much better. I wish they’d fix the Lima display drivers though, because it would be an excellent device if it had the same performance as the current OS, but could also run Retroarch and emulators reliably. I haven’t completely given up hope, but there have been lots of discussions (and complaints) on the forums here and very little response or indication that a new version of the OS is coming, or when it might be released. Even a quick tutorial of how to build a new version of the OS with updated/working drivers would be helpful, though I guess it could cause some chaos if there were lots of random user builds floating around on the forums.

In any case, I’ve resigned myself to only using it for Pico-8 and some other random stuff. The standalone PCSX ReARMed (available somewhere in these forums, but I didn’t grab a link, sorry) for Playstation emulation works great on the latest OS, with excellent battery life and full speed performance. There’s a stand alone Genesis emulator available too that works great too. Most of the rest are covered by Retroarch (including the systems built into the launcher), which is annoying in this case since they are unreliable now, if they work at all. :frowning:

I ran with the 2.1 OS when I first got my device and liked it for emulation, but performance was poor and battery life was also poor since there wasn’t much optimization. In the latest OS things are optimized and it’s a great device… except for most emulation. I’m still holding out hope for a fix one day.

And yes, you should be able to wipe and reflash the SD and go back to older versions of the OS. I haven’t done it myself, but others on the forums have. It’s probably a good idea to search for and read some posts about that.

You may want to start completely from scratch though. It sounded like there might be some issues if you try to move files back in place since different launcher versions may look for or store files in different places and configurations and things might get messed up. Starting completely from scratch with a fresh OS image would be the cleanest way.

It’s also worth noting that games/apps/emulators and customizations (like skins, icons, and where they live) to the launcher that have been posted to the forums may be OS version dependent. Some posts refer to that, while others don’t. And it seems there are two user bases running 2.1 and 3 right now, which causes confusion when people have questions and issues. It’s kind of a mess, unfortunately.

I still love my GameShell for the hardware, for what it can do, and for the potential of what it could do, and I think they’ve done a decent job with both the hardware and software. It’s the updates and community management that leave a lot to be desired. And it’s painful to see people get frustrated and ditch their device because it doesn’t work well (even though it could be updated to do so. I figured this was more of a tinkerer’s device, which is partly why I got it, but it could be a stable and good emulation platform if they wanted it to be. It’s not clear anymore what it is now, and the longer that continues the more likely it will be to languish in obscurity like a lot of other promising platforms before it. :frowning:

Thanks for your help! I appreciate it. Since my GameShell is brand new I don’t mind starting from scratch, and I don’t mind potentially missing out on themes/icons for a bit (they seem nice but not required). I’ll do some more tinkering soon and hopefully get stuff working. I don’t need it to be a perfect emulation machine, I just need it to actually, y’know, function at all.

I had to wait for mine for longer than usual because it was out of stock on Amazon, and I got it in the first place because I’ve seen a lot of buzz around it as an emulation machine from various sources (Kotaku had a good writeup recently) and because several people I know in the game industry had bought one for hobbiest reasons, so my gut says that it’s not yet doomed to languish… But I do hope some of these big issues get addressed sooner rather than later, otherwise it does send a bad message.

also you can try Settings->GPU driver switch chose FBturbo ,see if there is difference

Good news! I re-flashed the OS… but I went out on a limb and actually put 0.3 back on there. What I made sure not to do this time was update RetroArch itself. I left it on whatever version came stock.

Games are actually working wonderfully now. I’ve tried a few cores across a few systems and have not run into the same black screen problem I originally posted about.

1 Like

Good to know

the GPU driver in v0.3 is lima ,which is an open source reverse-engineering mali400 gpu driver
not quiet stable yet

If you enter a black screen or something on a game again, you can try Settings->GPU driver switch chose FBturbo for testing

I’ll keep this in mind, but I just double checked and FBturbo is actually the option that is selected by default, and I tried both it and lima (after reading your comment earlier) while trying to diagnose the problem.

Oh wow! Congrats. I’m tempted to re-flash to a clean 0.3. I never tried the original version of RetroArch, figuring compiling the latest would bring improvements and run better.

I too recently got a GameShell for Father’s Day/my birthday. For the most part, I’m loving it, but I’ve been having the same problem you’re having pretty often. I reflashed 0.3 on a separate SD card to see if a clean install would do the trick, but no dice. I haven’t updated RetroArch or anything, but I think I might try that just to see if it changes my situation at all… I’ve just gotten into the habit of hard rebooting the thing more often than not.

Bummer, sorry to hear that. What cores have you been using? I’ve had good luck with mGBA (unclear so far if it’s unlocking RetroAchievements.org achievements like I’m hoping, but games are at least registering as played), SNES9X 2005 and Gamebatte, but haven’t run through any others yet.

I’m mostly using snes9x 2005 and mGBA. I’d say those two work about 80% of the time. Nestopia is a 50/50 crapshoot, and Gambatte has never given me anything other than a white screen with sound.

try ssh into GS

cd ~/launcher && git pull

then chose lima in Settings->GPU Driver Switch ,Then Chose Fbturbo in Settings->GPU Driver Switch

I think it will fix the unstable issue

1 Like

I think that did the trick! Gambatte actually works now, and I haven’t had the no picture problem for any of the emulators for hours, now. Thanks!