Gameshell doesn't power on


#1

I’ve seen a few topics here on this issue, but nothing I’ve tried seems to work. I’ve listed what I’ve tried below

  • Disassembled and checked connections
  • Removed keypad and speakers and tried with just battery, screen and mainboard
  • Check with just screen and mainboard
  • Checked SD card was properly seated
  • Checked screen was properly seated

Is there anything else that I should try? Any help or pointers would be great :slight_smile:

I notice that when I plug the mainboard into power, I see a green light for a few seconds before that disappears.


#2

Connect it all but don’t out the battery in the case. Plug USB in and hold the power on button for a couple of seconds. If it works then it’s your battery.

If your battery fully charged? If not and you plug in USB cable then leave it for a but to charge. There’s no light indicator when it’s off to show a battery being charged.


#3

No luck with that either :frowning:

I tried with both the on/off button and the reset button. I tried a regular press on both and also a hold down for a few seconds too.


#4

If you plug in with USB do you get the LED on the mainboard at least? Or do you not get any response whatsoever?


#5

I get a green light for a few seconds and then it disappears.


#6

Well you get a light at all, that’s something! Would you be able to upload some photos of your connections? Maybe you missed something.


#7

The four connections that I have, let me know if you need to see anything specifically.

Yep glad about the green light, gives me some hope!


#8

have you tried the reset button, as found in this post:


#9

Yep tried the rest button too.

Thanks for posts so far :slight_smile:


#10

My mistake, I just noticed you did say that in a previous post. Well, if everything is connected properly and you are evidently getting power to the board, then we might have to concede that there is something amiss in the mainboard, that its not completing the power-up sequence. Perhaps you should email help@clockworkpi.com for some advice.


#11

no worries :slight_smile:
Thanks, I’ll give that a go


#12

For testing purposes, nothing needs to be connected to the logicboard other than the display. If connecting the USB power does not start the GameShell, then the likely culprit is the microSD card. Try flashing the clockworkos.dmg file to another 8G or larger microSD card and try again.
If successful, you can the reflash your original card.


#13

@lasvegas Just to check I understood, did you mean flash the OS to another SD card and try again?

If that’s what you meant, I tried that this morning and no change. Let’s hope that ClockworkPi respond to my email soon.


#14

If you tested all the above suggestions, it might be a defected main board. We will send you a replacement board, please check your email.


#15

would the sd card being corrupt stop it from even triggering the LED for charging and power?


#16

running into the same issue.
had loaded other emulators, and it would get stuck at loading. so I imaged the micro, while card was out and in laptop, I had the gs on charger, yellow/orange LED working. popped the micro sd in and pressed power, but no LED. no LED when charging now either. used multimeter to check power, its coming from the battery and reaching main. power fluctuates it as it should, but nothing to screen, no LED


#17

No display usually means the SD card is corrupt. I recommend the you install the original clockworkos_1.21.dmg on another SD card to test.


#18

@Nicholas_Hess Check my first post and use it was a check list, add to that a reflash of the SD card. If all those things don’t work it will be a mainboard/hardware problem and you’ll need to get in touch with customer support to get a new board out to you.


#19

So I had another main board sent to me by @yong.

I’ve been away so haven’t been able try again. This afternoon I gave it another go and still having issues. Main board is giving me an orange light with screen, main board and power plugged in, but nothing else

Any ideas what I should try next?


#20

SOLVED! it was the image(somehow) I mixed up the card from my retropie

THANK YOU GUYS!!!