GameShell won't recognize my 64gb card

You can also run a Virtual machine using something like VMware, and run Ubuntu on that. I think you can get a free trial for 15 days or something. There are probably free versions out there too. It’s what I personally use for quick fixes, Eg when you accidentally over fill your game shell and it won’t start up ;).

You might also give it a try by installing VirtualBox on your Mac and running a LiveUSB image of gparted. Works for me ! Let me know if you need help with setting that up, if needed I will make a short write up so other users also can use it.

1 Like

Maybe we could pack a distro with tools for liveUSB or emulating.

But for just expanding the fs, it can be done from within the cpi with SSH

I have tried every partition utility I could find for the Mac and have yet to get a clean expansion. It seems manipulating the partitions from the Mac destroys the boot flags in the partition structure. I’ve tried manually correcting them without success.

Doing it from a linux VM works fine as long as the VM app supports direct connection to USB devices. By far the best solution at present is the script that @Petrakis noted above.

1 Like

@guu wrote this fantastic tutorial up, on how to implement an auto expander.

And here’s a stock image with the auto expander already implemented.

1 Like