Expand File System

sd-card
filesystem
tinkering

#1

The Raspberry Pi has an option in the “raspi-config” script to resize the file system to the full size of the storage volume. I’m using a 64 gig card and can only use 7.1 gigs until I figure out how to resize or expand. Any help? Also it’d be cool to add that somewhere.


GameShell won't recognize my 64gb card
#2

You can partition the extra space and just mount it


#3

I used Gparted on another system to extend the partition. If you already have a Linux system or a Ubuntu Live Drive it is significantly easier with less fear of corrupting the card.


#4

Not super great to create a new partition when the system does not expect it.

Using the same method as what is done on the Raspberry Pi would make more sense.


#5

I tried Gparted and when I was done the GameShell wouldn’t boot. @QuantumKraken what size card did you use?

Fortunately I backed it up but now I’m back to only having access to 7.1 gb of 64.

@Godzil unfortunately raspi-config does not exist in your code. If someone can fork it and add it to gameshell and call it clockwork-config or something, be my guest.

In the mean time I’m nervous about trying Gparted again. It takes a long time to restore a 64 gig image. Is there something natively in Debian that is part of our kernel that I can use?


#6

that’s not my code XD (not working for clockwork)

Of course raspi-config does not exist there as it is a raspberry pi only tool. But the way they expand the filesystem can be used on any system it is not rPi specific :slight_smile:

For those who want to play at home, raspi-config source are here:

and the method to expand the FS is part of it.


#7

if you say so… I’d just make a new partition and mount home there…


#8

I guess it’s the “get_can_expand()” method right?

I’m not quite confident enough to try to implement this on the clockwork pi.

And sorry, are you an Admin or something? I saw your badge and figured you were a developer for CW based on context.


#9

I used a 64gb card formatted as Fat32
All I had to do with Gparted was extend the second partition and confirm.


#10

And yes I didn’t expect raspi-config to be there I was stating the obvious to make a point I guess.

Based on this in debian it seems doable but really easy to screw up. Which is probably how I screwed it up:


#11

That’s a moderator badge, don’t worry I don’t bite, just trying to keep the forum organised, just ignore the badge and status :wink:

I’m a backer like most of us, and a user (well, when mine will arrive…)


#12

Thats exactly what I did. Not sure if I need to make it a specific size or leave a specific amount of space… But after doing that my GS didn’t boot. Rasperry Pi has some code in the raspi-config to do this:

I’m just not super confident in working with that code. I’m a featherweight programmer and only really know python well enough to do damage.


#13

So what do we need to do? I just popped in a 32gb sd card and only 8gb is shown.


#14

I used Gparted from an Ubuntu Live usb drive to expand the partition
However, do to the misfortune it has caused above I can only lightly suggest it at this point.

If anyone else has managed to expand their drive successfully, we would like more input into this matter!


#15

I try some way to expand space but no helpful.hope some one cangive some suggestion.


#16

I was able to expand the file system just fine.
I run Linux on my systems primarily, specifically Mageia Linux. I used etcher to write the image to a 32GB microSD card I had, and then went into Mageia Control Center to the partition management and expanded the file system to take up the rest of the free space. It booted and is working in the GameShell.


#17

OK, you mean we need expansion sd card by using another linux computer and reinsert to gameshell to use it. I understood.


#18

That’s how I did it. It’s usually best that it isn’t mounted when you resize a file system.


#19

I’ll try it, thank you for your help


#20

That isn’t a problem with the raspberry pi and raspbian with their raspi-config utility.