GameShell won't recognize my 64gb card

sd-card
filesystem

#1

Hey folks! I just burned the GameShell OS image unto a 64gb card. However, the Gameshell only recognizes 8gb. Is there any way to get the GameShell to recognize the entire card?
I am a Linux noob, so all advise is good advise…thanks.


#2

#3

After days of hard work I got it to resize to the full 64 gigs. Unfortunately still, anytime I have more than 7.1 gigs worth of data on the card the launcher starts to slow down (freezing as I navigate) and disconnecting from my wifi. I used ‘parted’ and resize2fs.

Running out of hope that I’ll get this working any time soon… without some help from a more talented developer… @hal?


#4

A solution by the developers would be much appreciated. 8GB is not enough.


#5

The only way I managed to get ClockworkOS to expand on a 64GB card is to write the original image to the card and then use gParted to expand the CLOCKWORKPI partition it to the end of the card. When booted for the first time it expands the OS to use the full capacity. Doing the same thing with a previously run image results in either a non-bootable or slow copy.

I’ve tried other programs to expand the partition such as “Hard Disk Manager” in Mac OS and command-line procedures without success. Only gParted from a live USB copy of Umbuntu worked for me.

LasVegas


#6

First, we need a Linux machine and a 32GB SD card.

1. Burning the system image to a 32GB SD card
Take 32GB card as an example which is on /dev/sdb, after burning the system image file, partition 2 only has 7.4GB

~# fdisk -l /dev/sdb
Disk /dev/sdb: 29.7 GiB, 31914983424 bytes, 62333952 sectors

Device Boot Start End Sectors Size Id Type
/dev/sdb1 8192 93814 85623 41.8M c W95 FAT32 (LBA)
/dev/sdb2 94208 15523839 15429632 7.4G 83 Linux

2. Extend partition 2

2.1 Delete partition 2

~# fdisk /dev/sdb
Command (m for help): d
Partition number (1,2, default 2):

Partition 2 has been deleted.

2.2 Create partition 2, set the starting address to 94208:

Command (m for help): n
Partition type
p primary (1 primary, 0 extended, 3 free)
e extended (container for logical partitions)
Select (default p):

Using default response p.
Partition number (2-4, default 2):
First sector (2048-62333951, default 2048): 94208
Last sector, +sectors or +size{K,M,G,T,P} (94208-62333951, default 62333951):
Created a new partition 2 of type ‘Linux’ and of size 29.7 GiB.
Partition #2 contains a ext4 signature.
Do you want to remove the signature? [Y]es/[N]o: n

2.3 Save changes and exit, confirm the partition size is 29.7GB

Command (m for help): w

The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.

~# fdisk -l /dev/sdb
Disk /dev/sdb: 29.7 GiB, 31914983424 bytes, 62333952 sectors

Device Boot Start End Sectors Size Id Type
/dev/sdb1 8192 93814 85623 41.8M c W95 FAT32 (LBA)
/dev/sdb2 94208 62333951 62239744 29.7G 83 Linux

3. Extend the file system

~# e2fsck -f -y /dev/sdb2
e2fsck 1.43.4 (31-Jan-2017)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
CLOCKWORKPI: 93039/482384 files (0.1% non-contiguous), 743512/1928704 blocks

~# resize2fs /dev/sdb2
resize2fs 1.43.4 (31-Jan-2017)
Resizing the filesystem on /dev/sdb2 to 7779968 (4k) blocks.
The filesystem on /dev/sdb2 is now 7779968 (4k) blocks long.

4. Mount partition 2 and confirm the file system size is 30GB

~# df -h
/dev/sdb2 30G 2.6G 25G 10%


Updated launcher from git, EPIC FAIL
Reformatting help?
#7

So much easier to use gParted in one simple step.


#8

I’m currently using a 128 GB SD card and it works great. Just had to use gparted to extend it to the full size after writing the image. Any other partition management software (e.g. if you are on Windows, etc.) or command should work great too.


#9

Using Win32DiskImager to read/write the image and a USB bootable version of GParted in order to expand the CPI partition did the trick for me too.

At first I spent an evening tinkering with MiniTool until I foud out that you can’t expand a Linux partition with a Windows based partition tool. Now everything works fine; and there’s no slowdown in the Launcher for me.


#10

Hey, I have decided to use a 64 GB memory card as well for my GameShell. I have Win32Diskimager and GParted, but I am confused on how to get them to make it so that my memory card is recognized by the card reader. Can you provide the steps for the process on how to do this please? It would be greatly appreciated.


#11

Can you explain the problem a little more in depth? Which card reader doesn’t recognize your SD card?

The steps of the whole process are pretty simple:

  1. read the image from the original SD card using Win32DiskImager and save it on your PC
  2. format the new SD card
  3. burn the image of the original SD card onto the 64GB one using Win32DiskImager
  4. boot Gparted from your USB drive
  5. extend the CPI partition into the unallocated space of the SD card

#12

I was just asking because I saw that others were having the trouble of their 64GB memory cards not working, I was hoping to avoid that issue ahead of time. Your steps are pretty clear so thank you for your help with that. I am currently having issues with getting my memory card to be burned with the Clockwork OS. I used SD Card formatter in order to reformat my 64 GB micro SD due to it being used for a previous device. Then I will burn the disk image onto the micro sd. Do I download the GParted as a file and then put it on to the Miro SD and then boot GPArted from the Micro SD while it is still in my PC, or do I plug the micro sd into the GameShell and then try to boot it?


#13

How did you read it with win32? As it lets you chose drive letter (and they are 2 partitions) I didnt think it was possible so I read it with dd

dd bs=4M if=/dev/sdx of=file.img


#14

You need to prepare a USB Stick to become a bootable medium running gparted. There’s an instruction for this on gparted.org.

The Gparted files don’t belong on your SD card.


#15

Yes, there are two partitions on the original SD Card. Win32DiskImager creates an image including both of them.

The drive letter you choose to read from only refers to the drive letter of the SD card itself; not the partitions on the SD card.


#16

hmmmm i used dd if=/dev/mmcblk0 of=/Data/imagename.img bs=64M and synced before extending the partition… also worked


#17

Yeah as long you dd back with the same block size, should work


#18

So if I clone my SD now, and use the cloned image on a new SD it will slow down? Did I understand that right?

Would be easy to clone what I have already, and expand but I don’t want to compromise the system at all

You could also create a 32/64GB img using WinDiskImager and host it. Then the people having trouble could just flash it already partitioned


#19

I have not had good luck cloning a previously booted copy of ClockworkOS. Copying the original ClockworkOS 0.1 image to the memory card and then expanding it with gParted works reliably. After booting the first time, it’s then safe to copy a previously backed up copy of the contents of the home folder (/home/cpi/) using SCP.

Backup:

scp cpi@[TinyCloud Address]:/home/cpi [Local Backup location]

Restore:

scp [Local Backup location] cpi@[TinyCloud Address]:/home/cpi

Be sure to reboot GameShell immediately after restore!

LasVegas


#20

thanks for the input man! Restoring everything back to a 32GB card.

What a process to repartition haha wow