clockworkpi

Larger SD card Problem

Hey people, i am in a dilema over here, any help would be appreciated.
So i gotten myself a SD-Card with more storage, flashed the OS onto it and tried to get the GS to realize “Oh wait! i have over 200GB of available space now!” but to no avail.
i tried it with diskgenius and a certain command by fellow user hpcodecraft, but i always end up with GS showing the following error message when i dare to rebooth :
-bash: /tmp/x.log: Read-only file system
If it is any help, my pc runs windows 10 and the new SD-Card is a SanDisk Extreme (the ones that are red and yellow instead of red and white) with 256GB of storage.

Thx

Hello there!! Welcome to the forums.

There was a similar post here:

Otherwise, have you tried using an image that is self expanding? Try this out:

Hi there and thank you for the warm welcome.

And this is a bit of a bummer but the first thread is actually one i tried to get some advice out of.
I have also tried to use a selfexpanding imagine but had the same problem.

At this point i am not sure anymore what to do.
Could the problem possibly be that i then proceeded to update the launcher?
Or is it maybe that new SD-Card, that is the problem?

Because at this point I’m considering everything.

It could also be your SD reader/writer! Try using a dedicated image writing program like etcher.
Or use a different computer altogether.
Re: self expanding images, let them reboot a few times to do their thing.
Oh dear. Another thought. You may have a counterfeit 256GB card. Basically the header tells the device it’s 256GB, but in reality it keeps rewriting over the same smaller card size.
I’ll post more links later! Gotta go to work!

I was just going to reply this.

If the cart is flashed to a fake size, it will report 256GB but it will be less, and filling it or formatting it it will corrupt it.

I like to use this https://www.rmprepusb.com/ to check them. In the past I was hunting fake usb and sd sellers and checking the things they sent me and opening disputes, that way I got a bunch of free cards and pendrives and I removed them from the market from non suspecting victims.

1 Like

Funny it was mentioned, I guess I should’ve mentioned it before but I use Etcher to flash the SD Card.

About the selfexpanding Imagine, how many reboots should i do? I would do a few more than necessary, just to be sure.

And i think I can we can rule the possibility of a counterfeit SD Card out, as i bought the Card fresh from Amazon.

Sweet Christmas that is some extreme altruism if I ever saw it! You’re an online shopper’s hero!! :smiley: I always abide by the age old adage: if it’s too good to be true, it probably is.

Re: reboots, the way the script works is a notification free reboot cycle, that on first glance, would appear to be a boot loop. As @Petrakis mentioned in another thread, this is technically not be good etiquette or practise, but alas. It is what it is for now.

It should just reboot itself automatically. Perhaps it just takes longer with a larger card? Although if it’s just writing a partition table, and not zeroing any space it shouldn’t be any longer.

On another note, I’ve got complete rom sets for basically all the Mame, Nintendo, and sega consoles and only use a 32GB card. Unless you’re planning on having a complete PSX ISO collection, 256GB is fairly overkill for the gameshell. Perhaps try using a smaller card?

OH WAIT HOLD YOUR HORSES - DID YOU TRY AND UPDATE THE LAUNCHER WITH THE IMAGE I MADE, specifically 191122? That is using some newer experimental Lima drivers that are installed in the user directory, as a temporary testing measure. Doing an update, specifically with that image will break it. Specifically, going into the system menu and choosing to update. That just does the launcher. I mean it shouldn’t actually break things, seeing as the launcher is separate to the user directory, but just a precaution! I’ve updated and tested it from my end.
So have you actually gotten it up and running like, ever? On your 256GB card that is.

Not with your Imagine specifically, no.
However I did update launcher from the settings menu. However that would lead to error mentioned earlier the next time i would try to boot it up.
Not updating seemed to work around this, however when i then try to move some roms onto the card (which i use filezilla for), then it would move like maybe 1 or 2 and then stop moving any more roms onto it, usually followed by the read-only-error.

From a fresh image, that shouldn’t change things. But the fact that it did would imply something is up. I’m guessing that was a completely fresh image, re update. No extra icons, or folder moving etc. that’s usually what messes things up. That said, it doesn’t explain the read only error. I don’t personally use FileZilla so I can’t really comment.

I used to use putty back in my days of using windows. Nowadays, I use CyberDuck or Transmit when not using a CLI. It could be client based? I also remember reading a thread re: the wifi not behaving well while connecting to an open wifi network. That could be a thing.

There could be some strange ownership problems with the Roms you’ve got. That could be causing the permissions error. Particularly, if they were recovered from a failed hard drive, where you have had to adopt ownership/become the parent user.

The good news is, you’re not missing out on too much not updating it. But still. It’s an annoyance, that’s for sure!

We could adapt armbian scripts which work very well: https://github.com/armbian/build/blob/150ac0c2afa147d9e3b036c8ecd8238fe5648cf3/packages/bsp/common/usr/lib/armbian/armbian-resize-filesystem

1 Like

Got a little update on the read only error :
This time i only flashed the card with the selfexpanding image (0.4), put it back into the GS and just manually rebooted it. After the third reboot it booted like normal, went to the happy-hacking screen and gave the read-only error again.
I also tried to flash the original 0.4 image again and expand the partition manually with diskgenius again, which got me stuck on the “debian gnu/linux 9 clockworkpi tty1” screen, asking mefor a login.

So at this point I’m really not sure anymore what to do, so I’ll just use the card that came bundled with the gamshell for a while and try a different card.
I’ll try to come back to this card, but for now I am a little burned out on it.

1 Like

The easiest way to do it is to use gparted on a free copy of UBUNTU and expand your newly imaged sd card. I’ve done it myself, but I used a raspberry pi 3b+ with gparted installed.

Here is a thread with a lot of info on the subject.

Nice, can you please create a torrent link with public trackers, so we could seed it?

Torrenting in Australia is a ridiculous affair, with the whole great firewall debarcle. Yay politics. It will be a lot of trouble, unfortunately. That said, if you check the OP, there’s a download link. Periodically I repost all the download links in the thread, to keep it current. I won’t post it here, to avoid cross posting/getting off topic.
By all means, you can seed it if you want.