Help! Trying to boot Manjaro-arm on Devterm CM4

Hi guys, I think I’m going crazy :smile:

I’m trying to install Manjaro ARM on my DevTerm CM4. First used a generic image, didn’t work. Next used the official rpi image and still no luck. Supposedly the rpi image already has the u-boot patch installed, but still nothing.

I have also tried to install Tow-Boot on the device, following all the official instructions. Doesn’t boot.

Also tried to modify the image using this guide as some of you recommended a while ago. I encounter multiple errors and can’t seem to install the packages. Oh my God!

Can you guys help me? I’d really appreciate it as I’m so frustrated :rofl:

Thanks in advance

Try using a HTMI cable and connect to a screen.

Those packages wont install because they are meant for Debian based systems.

If you want to use Manjaro, use Manjaro XFCE. The sections from that guide to get your built-in display working are as follows:

1: the section about configuring xrandr (tells the OS what display to use)
2: the section about modifying lightdm (this tells lightdm to apply the xrandr setting upon startup)
3: and the section about screen rotation

These changes will need to be made on a different system so please check out the archwiki guide on how to chroot chroot - ArchWiki