Hirsute went offline late July 2022, how to manage?


Thank you so much for detailing this, I was getting really frustrated in trying to get the thing to work properly (not overly familiar with Debian based distros) and this worked perfectly.

Yup, really annoying. The Clockwork team really needs to update their image on the website if nothing else. I imagine they might have a lot more frustrated people in the future who might not even see this forum post. I don’t think it is unreasonable to expect it to work out of the box without 5 hours worth of updates and patching.

Edit - spoke too soon. I was seeing if it would build a nodejs project and the whole system froze on me. I reset it by holding the power button but when it starts back up now it doesn’t seem to recognise the mouse or keyboard. The standard XFCE desktop shows up but you can’t interact with it. I saw this behaviour a lot with the stock image too and was hoping it was just related to it.
For the record I had restarted it a few times after the upgrade process and it worked fine.

Edit edit - I turned it off for a few mins, turned it on again and the mouse works again… I have no idea…


If the latest one is not an LTS release, there are ways to configure Ubuntu to only jump to the latest LTS, which you may or may not wish to do.

How do I achieve this?

I will want to perform these steps as well and it would be a really bad surprise if after 4 hours I find out that the version I got is not LTS.

I would really like to avoid having to repeat this.

To anyone doing this:
I highly recommend making a backup image of the SD card before.

Do we can expect that there will be an official updated OS image?

ETA: I found out that I should put Prompt=lts into /etc/update-manager/release-upgrades/.

But it says that if will not be effective if my current version is not an LTS.
So how to do it to have LTS unconditionally?
Is the current release an LTS?
How to check?

ETAA: I did this and the menu bar changed to whire :slight_smile:
also it is complaining about the one from /etc/apt/source-list.d/clockworkpi.list

so when I try to do this, I get an error saying:

pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.

Any idea what I may be doing wrong? I made sure that I updated the URLs in my sources file.

Any idea what I may be doing wrong?

Nothing; keep waiting! I got the same thing (I’m doing this right now, as we “speak”) and I just let it sit. About 20 minutes after this lspci: Cannot find... message there was more activity, then it said it was about to start the upgrade and it could take several hours (it’s underway now).

So just leave it; I think you’re underway.

Here is the A04 os image with Armbian 22, LTS ,end at 2037

with all the stuff like previous os image


for A06


Ah, unfortunately mine will say that it can’t find a bunch of repos and then it says that it’s restoring the previous system state and does not do the upgrade. I am going to try the image that Guu posted!

maybe it could be related to the situation that apt.armbian.com is currently returning http error 500 all the time?

I believe that this is the issue that I am facing, as a lot of the repos give that error

It’s certainly odd that we are using the same computer and same image file, doing the same thing and getting different results. Nonetheless, I waited, and it eventually completed. It took all night and finished some time today. It might have finished earlier but there were about a dozen instances where it stopped to say that there was a file in the new updated version that differed from the old version and did I want to use the new or keep the old (funny that the default was to keep the old – I would have thought the default would be to use the new, since it is an upgrade, after all). In other words, I did the opposite of arru in post #5 and used the new version of the file in question.

Anyway, it finished, so this is to say that it @arru’s description worked for me; but now I guess I start all over since @guu posted a new release today (DevTerm_A04_v0.2c.img.7z) in post #21.

Just about to give it a try, just one note, it would be easier if it were compressed as .bz2 like the rest of the images rather than .7z.

OK link updated
it is bz2 now


The out of the box image seems to work, printer works etc. but the moment you try to do an apt update && apt upgrade it will upgrade without error but then refuse to turn on again after being shut down (backlight comes on but no screen output).
I’ve already written the image 4 times in case it was something I missed with the replacement of config files during the upgrade but it seems entirely broken no matter what options I choose.
The image also still has the issue with the top pixel row of the screen showing at the bottom.

did you use the 7z version ?

I tried with both 7z (which I had to extract first for Balena Etcher) and bz2 which works natively with it.
Both images work fine on boot and both restore from shutdown, it is just when performing updates that causes them to break.

There is also something funky going on with the SSH stuff. It still shows a readme on boot about ssh being disabled but:
/etc/ssh/sshd_not_to_be_run does not exist and systemctl status sshd shows that ssh.service is running.

I haven’t tried @guu’s v0.2c version yet, after seeing the problems mentioned in the most recent posts, so I’m still on the v0.1a image which seems to be working (though I’ve not tried much yet). But really what I wanted to ask about was this comment from @arru about re-enabling these sources. They all say that they have been disabled on upgrade to jammy. So they need to be put back in spite of this?

Caveat: this is my own, quite amateurish interpretation of the desired post-upgrade configuration:

/etc/apt/source-list.d/clockworkpi.list enable because it supplies ClockworkPi-specific packages with hardware support

/etc/apt/source-list.d/armbian.list keep disabled because there is no native support for A04 in Armbian, yet. A06 should be supported, but I can’t confirm it myself

others in this directory will depend on exactly what you have installed previously (if any). My tip is to change those from hirsute to jammy and try if that works, keep disabled if there are errors.

1 Like

upgrade issue fixed in DevTerm_A04_v0.2e.img.bz2

I forgot to mask kernel to prevent from upgrading

so that is why after upgrade ,can not boot


hey, registered here just so that I can get some clarification about the image @guu 's posted.

Is it normal for the balenaetcher to be that long? or something’s wrong with the .bz2 image posted?

EDIT: tried with the 0.1a old image to see if the problem’s on my laptop’s usb but that one’s fine, took only 20 minutes tops.

456m is too long
0.2mb/s is too slow for USB device

but the size of the image seems ok

I dont know where is the problem , guess the USB port issue

I don’t have this problem at all, the 0.2d image flashes in about 10 mins or so for me with my laptop’s inbuild SD card slot. Not tried e yet.

@guu I’ve been running the d image for the last week or so. It has been very stable and everything works so far. What has been changed between d and e?