clockworkpi

How to add new emulators (Gameboy, SNES, etc.)

There is an optimized snes9x you can find on this forum same goes for picodrive there is a retroarch core in one of the threads

Hi.

I’m a noob when in comes to this coding stuff, and I came across a issue when following the tutorial.
There isn’t a directory in my GameShell that is the following:
/home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/
This also doesn’t work when ‘20_Retro\ Games/’ is replaced with the listed alternatives.
Instead, I have the following:
/home/cpi/launcher/Menu/GameShell/20_Retro Games
I was wondering if this would be the directory that I would create the folder, and use when following all of the other steps.

Thanks!

I’m having the same issue. I was able to install a few emulators, but I used the new script on here to expand my memory card and now I don’t know how to install anymore emulators because the file structure is different

i also have this issue plus when I type the code without the apps word, it says “too many arguments”
pls help ASAP

I copied the path from the github repository (and there it was with apps) as I didn´t have my Clockwork at hand. So use this one:

cd /home/cpi/launcher/Menu/GameShell/20_Retro\ Games/

or

cd ‘/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/’

this works but I get the code “too many arguments”

Okay I found the reason…

The forum changes the ’ character because I used the blockqute instead of code format, try and copy this one.

cd '/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/'

image

I used this one and it worked:
cd /home/cpi/launcher/Menu/GameShell/20_Retro\ Games/

Thanks so much!

What should be put in the “action.config” file to hide the extensions? I would like to be able to hide the .bin files from PSX and only the .cue will appear, that there are games with multiple .bin files

if you open the action.config file for your PSX emulator, you should see a list of extensions next to “EXT=”
if you remove “bin” from that list, and then reboot your gameshell or reload the UI, it should only show the cue files or whatever else

I have the same problem, everytime i try to enter in a game appear the message “Do you want to set up this game engine automatically?” i say “yes” and the game will not start

Same problem with the “Do you want to set up this game engine automatically?”

Seems to happen when the link to the core is not correctly set up in the action file. It will then try to download the core from the url you provide in it. If that url is also not correct I assume it won’t start. So I guess the easiest way to fix this would be to locate the cores on your GS and use the correct path so it doesn’t have to download it again.

hey.
i have Little problem, when i write" cd /home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/ " and it says “no such file or directory”. and i tried writing " 20_Retro Games/ " too and it doesn’t work either.

Heya! Welcome to the forum!

Unfortunately the directory structure has changed since this post was written. I’m assuming you’re in Clockwork OS 0.4?

Try this instead:

 cd '/home/cpi/launcher/Menu/GameShell/20_Retro Games'
1 Like

thank you it worked, the GBC is on the retro games menu, but the ui doesnt show like the other emulators

1 Like

Was this to do with installing a standalone GBC emulator? Which one out of interest?

If you’re using Clockwork OS 0.4, if has most of them installed already.

Standalone emulators don’t have the same interface as ones that use Retroarch. This makes them run faster in some cases. They’re entirely there so you have a choice of different emulators to use.

Another thing I want to point out is that this thread is half a year old, and a lot of the information is outdated, eg the file structure.

Have a look at this thread for something similar, but more up to date. This is if you want to use Clockwork OS 0.3.

where do I get the roms?

You will need to search for them external to this forum. If you know the name of the console you want Roms for, you should be able to source some pretty cool Roms.

I am trying to play some PC Engine CD games, but with no success.
I have downloaded the bios already placed it at cpi/home/games/PCE/Super CD-ROM2 System V3.01 (U).pce

I am using the mednafen_pce_fast_libretro.so as the core of the emulator. Any idea of what I am doing wrong? Also placed the .img, .ccd, .sub and .cue files at the games/PCE folder.