How to use RetroArch in Gameshell?


#1

I downloaded several cores and copied my own ROM, but still cannot play.


#2

Since most of us on the forum still have not received our Game Shells yet (so we haven’t tried it ourselves), you may want to contact help@clockworkpi.com for assistance with any technical issues getting the Game Shell to work.


#3

Or perhaps PM users who have got it to work (gray area the emulator zone) :wink:


#4

I’m a RA dev, just received mine.
Key layout seems completely broken.

Is the joystick actually a keyboard?

I’ll try to figure it out give me a couple days :slight_smile:


#5

ok, step 1, ssh into the thing, then do

nano .config/retroarch/retroarch.cfg

Find unified_menu_controls and enable it (true)

Now you can control the menu :slight_smile:


#6

Ok so far input is a chore because keypad is… well a keyboard and that sucks, but it can be worked around at least.

For some reason the video is initialized as 960x720? so you have to set a custom viewport (it’s done with a default config in the CPI)

Why? can’t we use native 320x240 and save some CPU?


#7

With some tinkering managed to build a workable version of gpsp (faster than mgba), working dynarec and all, it’s running fullspeed

You can get it here: https://files.andressm.org/d/439d852b9ed243f9b296/

I’ll keep adding stuff I fix to that folder.


#8

How do you install the package?


#9

What package? it’s just a core, download the .so file and move it into ~/config/.retroarch/cores


#10

The SoC is not half bad, it’s the SoC in the NES/SNES Classic.
I hope we get GPU drivers sometime.

After a day of tinkering I got this:


#11

Tried your gpSP but with the RetroArch built in but cannot get any rom work with it. Is it necessary to upgrade the RetroArch or additional configuration is needed?


#12

You need a bios file


#13

FWIW, performance is not stellar even if it looks fast, this is using threaded video, in many instances there are tons of frame drops, but the threaded video masks the issue.

With proper drivers it might become really usable though.


#14

Just for kicks, how does the jaguar core run?


#15

The only reason pcsx and gpsp are fast is because they have ARM dynarecs and NEON enhancements.

Still, guess I can give it a shot.


#16

Anyone got the snes emulator to run yet ? PM me :wink:


#17

Literally all you have to do is go to core updater, download snes9x and then load a snes rom


#18

Nice! Was using the wrong core then :hugs:


#19

I put my roms in the folders that are in the main menu system for “retro games” but I guess that doesn’t work. I am confused as to why there are mutiple rom folders, why some are detected after scanning and not others, etc. etc. I wish this was as streamlined as something like RetroPi with Emulation Station but I guess it will just have to get there over time.


#20

Thanks @fr500. Psx games working at playable speed.