How to start Games from Menu> retro games>emulators

I now startup the games from retroarch> load content.
But how do i setup/start the games from menu>retro games>emulators?

1 Like

Good question GBA games will work if the roms are in the games>MGBA folder.

I would like to know how I can add another system/core from RetroArch to this screen. Like SNES especially.

I also want to know this because failed to do so.

Same here. I put the NES roms I had in that folder and scanned and it does not recognized them. Only GBA is working for me.

Rene the problem could be if your files are .nes. They set that folder up to only recognize .zip nes roms. I put in a request to change that by adding .nes to the list.

1 Like

Well, that sounds like the culprit! I don’t have any of my stuff zipped! Thank you!

You can add ‘nes’ to the folders action.config file

launcher/Menu/GameShell/20_Retro Games/NESTOPIA/action.config

Line 3 says:

Just change it to:

Then save and reboot. Unless you would rather zip up all of your roms.

1 Like

Going to do that right now! Thank you!

1 Like

The only ROMs working for me are the NES roms, the GBA and MAME are not working. Is there a way to go back in Retro Arch? I’m new to it, and can’t make heads or tails of it. We should be able to run all ROMs from inside it right?

I make new folder called SNES and put a new action.config file in it. But it keeps asking me download the SNES core even if I have downloaded. Anyone knows why?

I did this with the Genesis core and got the same effect. I went into retroarch, downloaded the core there, then return to the menu and it worked.

I don’t know if it worked due to reloading the menu or the installation of core.

The core itself works inside the retroarch. But when using it from the Retro Game Menu entrypoint, it keeps asking me downloading the core again and again.

You might need to scp into the gameshell and place the files yourself. I think the .zip and core goes in home/cpi/apps/emulators.

I’ll see if something specific needs to be done to make these custom action.config files work firsf try in the morning

Yes, I scp into the GS and have put the core in /home/cpi/apps/emulators, still have the problem.

Have you double checked the action.config file? No typos?
If the files you entered into that file are there, it shouldn’t ask you to download again.

You put BOTH the .zip and the .so file in there?

If yes to both, I am officially stumped.

As there are rom path and core path in the action.config file, i just put my roms (.sfc) under the rom path and core file in the /home/cpi/apps/emulators .

I mean the .zip file that contained the core. I think it is looking for that zip file under emulators when it asks if you would like to download.

The zip you told the action.config file to download in the first place

The zip also exists.

Theeeeeen there isn’t anything further I can suggest
Sorry man, I wish I could have of more help

Thank you for replying me. I will try again and let you know if something I am wrong.