Installing Box86/Box64/Wine x86

Is Diablo possible? I think there is a Linux native binary available?

Only thing I tried so far with box86/box64 installed was Zachtronics superb TS-100, which runs, but is scaled weirdly (I think down to 800x480?) making text unreadable and thus the game is unplayable sadly.

Someone made a Gameshell port of Diablo a few years ago, and I’m guessing it will run fine on Devterm too. Looks like the build process is pretty easy, but I haven’t tried it yet.

Oh I played the ps1 version on the Gameshell, I have to try that project

Forget about PiKISS for the A04 and A06 cores. It refuses to run on anything else other than a Pi. However, you can still take a look at the PiKISS git in the scripts folder, there are a lot of interesting things to install (x86/x64 and otherwise)

PiKISS is a nice collection of scripts accessible through a menu to install various things. It includes the install script for Diablo, I believe.
I am not sure if PiKISS works out of the box on the A04 and A06 cores, but worth a try.

Anyone have this working on DevTerm A04?

Installing box64 works fine, the only change from the script being defining ARM_DYNAREC instead of RK3399, when calling cmake, that is:

sudo apt install cmake
git clone https://github.com/ptitSeb/box64
cd box64
mkdir build
cd build
cmake .. -DARM_DYNAREC=ON -DCMAKE_BUILD_TYPE=RelWithDebInfo
make -j4 # assuming all 4 cores are enabled
sudo make install

However, I’ve been unable to get box86 to build. The compiler complains about the -marm option, the -mfpu=neon option, and the -march=armv7-a+simd option. The last one worries me the most, since isn’t the point to compile armv7 code (for 32-bit)? And the error suggests that the compiler can only deal with arm64 architectures:

cc1: note: valid arguments are: armv8-a armv8.1-a armv8.2-a armv8.3-a armv8.4-a armv8.5-a armv8.6-a native

Anyone have this working on DevTerm A04?

Using the armbian-gaming.sh I was able to install both box86 and box64 without any additional changes on my A04 DevTerm

Hm, I’ll try that. But the script compiles against RK3399, that is, the A06 SOC. With A04 we are running Allwinner H6. (See A04 potential X performance problems + potential solution - #5 by annathyst)

Do box86/box64 work for you?

Do box86/box64 work for you?

They seem to work, but I haven’t been able to test this thoroughly, since my screen keeps dying a few minutes after boot. I guess, I will have to contact @AlexDuan by mail to get a replacement after all.

Zachtronics TIS-100 started, which I think is x86

Zoom conference client x64 started aswell and seems to work well, even with UVC webcam plugged in, except for a few graphical glitches and the screen being to small to actually be useful (might have to experiment with screen scaling for this)

Ok, based on your comment, I also used the armbian-gaming.sh script to build box86 only, and it seems to work! I also tried TIS-100, which is indeed x86. It seems fully functional, although, just as you say, it’s going to be challenging play on the tiny screen. Great tip, thanks.