Installing IDLE and jupyter notebook on DevTerm A0604

Hello All,
I have rand the pip command to install idle and Jupyter notebook on the Devterm A0604. However, when I run the commands IDLE and jupyter notebook in the shell, they don’t launch the programs and return unknown command error. I checked the GUI and jupyter notebook is shown under applications in the menu but it does not launch it when clicked.

have you checked ~/.local/bin ?

Of course. The Jupyter files are there and permissions are also correct. However when I run the command it does not recognize it as a command. I browse to that directory and issue command. I even tried to launch it from applications, it shows error.

I am not sure why IDLE is also not recognised.

Can you paste in what exactly you are typing in the terminal and what’s the result? Or take a screenshot?

cpi@clockworkpi-a06:~$ which pip3
/usr/bin/pip3
cpi@clockworkpi-a06:~$ pip3 install idle
Requirement already satisfied: idle in ./.local/lib/python3.9/site-packages (1.0.4)
cpi@clockworkpi-a06:~$ idle
-bash: idle: command not found
cpi@clockworkpi-a06:~$ idle3
-bash: idle3: command not found
cpi@clockworkpi-a06:~$

Jupyter notebook is working now. But the IDLE issue is still there. Can you please help? I will use all this knowledge to create free tutorials on Youtube and a free course on Udemy.

um, that’s not how the pip-installed idle works. you should use the system package manager to install idle.

or you could just “import idle” in python and it’ll hopefully pop up.

On mine, I made an icon that runs the command “/usr/bin/idle %F” and that worked.

cpi@clockworkpi-a06:~$ pip3 install idle
Requirement already satisfied: idle in ./.local/lib/python3.9/site-packages (1.0.4)

Well, it does warn you (in the logs you omitted) that ~/.local/bin is not in your PATH.

Hello folks,
Thanks a ton for offering all the assistance. I have tried a few things and following sequence of commands works for me,

sudo apt install python3-pip
sudo apt-get install idle3 -y
pip3 install jupyter notebook jupyterlab
cd ~
sudo nano .bashrc

Add the following line to the .bashrc file,

PATH=$PATH:~/.local/bin

Exit and restart the shell.

Thanks a lot again for all of your assistance. I will ask more questions when I get any issues.

  • If you apt install idle3, you don’t need to update PATH to include ~/.local/bin
  • Don’t sudo edit your .bashrc

I had to add the bin directory to the PATH for Jupyter.