clockworkpi

Lack of low frequency

I found that the headphone output of Gameshell can not output any low-frequency audios. It means that no bass in music and games. Is it there a solution to solve this problem?

1 Like

Agreed. Not just the headphones, but the built in speakers too. It would be great if we could use a dedicated breakout DSP board, using the GPIO pins.

Ive been messing around with DSP filters, at least for Retroarch based cores. I can get it sounding a little better. Here’s a quick link:

There’s a way to edit the EQ of the MPD music player.

https://patrick-nagel.net/blog/archives/180

As for standalone emulators, I haven’t tried to find a way to balance the audio.
I think that’s just the audio quality of the onboard sound processor being what it is.

How a breakout board will help? Usually gpio is the slowest interface and sound is analog, meaning thats too much for a gpio

Ive seen other boards hacks with the usb soundcards

2 Likes

For proper audio, there is a serial bus that are especially made for that: I2S (not to be mistaken for I2C)

The audio is comming out directly from the AllWinner SoC (wow :S)

Have you tried different headphone?
You may face an impedance issue where the ClockworkPi expect, let’s say 8 Ohm headphones, yours are 4 Ohm, and bad things happen like lack of bass.

I haven’t look in the TRM, but on the schematic, I see no possibility of having an external codec, I see no I2S bus on that SoC.

Also as stupid as it sounds, you should check how the audio is configured, the system probably have some integrated filter (like histograms) and it may by default put some attenuation on the lower frequencies, like because of the small speaker the system come with by default.

My headphone model is Sony xb-50 Extra Bass(16Ω)I also tried a studio headphone, but also lacking low frequency. Is there any ways to configure system’s audio filter?

I managed to achieve a reasonable amount of low frequency with this bass boosted edit
https://www.dropbox.com/s/dk8df0jn4l7fhx7/Marshmello%20-%20Alone%20%5BBass%20Boosted%5D%2044100.mp3?dl=0
It sounds insane on a normal device(way too much bass). But it sounds like a normal un-boosted song on GameShell.

By the way, gameshell’s bass output sounds very clean and comfortable(based on that bass boosted song)

1 Like

Nice! I was messing around with something similar. Was this based just on a DSP filter within Retroarch, or a global setting?
I was also looking at how the MDP EQ could be edited, but that was just for music.

Ah I just realised: this is just a posted mp3 file with boosted bass. Here is the info I was going to use to globally modify the EQ of the audio on the gameshell. I’ll look into it more on the weekend. Maybe. (I am very tired lol)

https://patrick-nagel.net/blog/archives/180

Just a thought. I was fiddling with the gameshell, taking it apart while it was running/playing music. Having the speakers facing correctly “up” so that the gameshell logo is facing the transparent side makes a significant different to the sound. Having no shell, and/or facing backwards has a shocking sound response. Perhaps the speakers use the entire front shell as a vibrating panel, allowing some lower frequencies to be heard.
That said, it is still less than I would desire. Just thought I’d mention that in case anyone is experience tinny audio due to an installation configuration.

I searched all possible places but can not find anything about filter. Looks like gameshell is not using PulseAudio. I want to know which audio mixer gameshell is using so i can look into specific config file.

1 Like

so far, i’ve found the only solution to get a good sound - use an external USB DAC with line output, or USB Sound Card (USB headset/headphones).
but, unfortunately, while some OSs (Windows, Linux (e.g. Ubuntu), Android, even Windows 10 for Mobile) are capable to automatically swith audio output to a new audio device, ClockworkPi does not. it can successfully detect USB device, but you will need to use it somehow.
for now, i use Kodi. but setting it up on such a low-resulution screen, it’s a real pain. anyway, you can swith audio output device in the application settings, and listen to the music with a much more better quality output, than from GameShell’s headphone jack.
the next drawback, is that not every USB device will work OK. in my example, while Kodi can see USB DAC, and allows to select it, the sound can’t be routed through it. one USB headset for some reason has a really quiet sound when connected to the GameShell. and only one USB headset works great, and capable to output a nice, loud sound… but, it’s headset for talks… it’s not any good headphones with a reach basses.
and yeah, it’s a really bulky and fragile solution. but from what i know, ClockworkPi does not support Bluetooth audio devices, so external USB audio device is the only solution for the great sound.

p.s.: i don’t have headphones amplifier, so can’t check if it’s help somehow. but, so far i’ve tried in-ear headphones with impedance 14, 16 and 18 Ohms, and can confirm a lack of low frequency.

2 Likes

That’s really interesting… Probably this issue now have nothing to do with software filter, and it’s just a problematic audio circuit design.
We really need some experts here.
Maybe Yong can help us?

1 Like

One more thing. I tested the sound of HDMI, it also sounds bad. The HDMI signal generator chip contains a DAC, but I don’t know if it’s being used or not. If the HDMI uses it’s built-in DAC, we can start to investigate gameshell’s software. If the HDMI uses CPU’s DAC, than it might be a circuit issue.

1 Like

Update guys, I just got a cheap SoundBlaster Play3, the audio sounds awesome! High frequency is clear and low frequency was super powerful. Looks like it’s gameshell’s hardware issue. But there are other issues preventing this method to be the best solution. First issue is that gameshell Launcher does not support volume adjustment for external audio devices. Try to Shift + plus or Shift + minus will freeze the Launcher. Besides that, even on lowest volume in alsamixer the music is still very loud.

1 Like

Update again, to resolve the volume and launcher issue that I posted above, you need to install pulseaudio.
sudo apt install pulseaudio
After that, reboot the device. If you accdentally freeze the launcher, use “sudo systemctl reboot”.
Then, follow this webpage https://chrisjean.com/fix-for-usb-audio-is-too-loud-and-mutes-at-low-volume-in-ubuntu/ to adjust the volume to a reasonable value.
Finally, execute “alsamixer”, use F6 to select your USB sound card and adjuest the alsa volume to a reasonable value.

Please note that this trick will only work in gameshell launcher. It will not affect retroarch emulators.

Enjoy your gameshell audio with BASS!!!

1 Like

Hi! I am sorry to disturb you, I know clockworkpi in gameshell has 14 pins can be used as communication pin to connect with other devices with UART/SPI/I2C, but I don’t know how to control gpio in software. I have seen this page but It seems people in the page has no idea to control it in /sys/class/gpio. And then I seen this page, it’s a video to teach how to control gpio in orange pi, but the orange pi has larger difference with clockworkpi. Do you get some experience in clockworkpi gpio control? Can you help me?

There is little that can be done, for audio purposes, using the IOs on that connector. SPI, I2C or RS232 are not well suited for audio transmission.

What where you thinking about?

Not just audio devices. For example, you may can connect some uwb chip like dwm1000 with clockworkpi. There are lots of things can be done with communication IOs. When I search IO information in the forum, I found this post, had someone talk about GPIO pins, so I came here ask for help, not just for audio. :grin: