New uConsole : nothing on screen

After my DevTerm, I was happy to order a uConsole.
After more than 90 days, I finally get mine at home.
Unfortunately, after careful assembling, nothing seems to start when I power up.
I used usb C power and I see that the core board has power led on, but nothing appears on the screen.
Is there any other way to test and understand what is wrong ?

Same issue. uConsole arrived today.

1 Like

Try flashing the SD card, sometimes when I corrupt my card it behaves like that.

wrong SD card and nothing appears on screen?
ok, I can flash another one to check, thanks.

I tried with 2 other sdcard, nothing appears

I had the same problem : I didnt plug the screen the right way. Check the connexion maybe!

I have similar problem with large SD card(1TB), then switch to 32GB SD and everything works great!

Also, for R01 core modules first boot may take a time.

funny! I juste received a 512 Sandisk, put the image ont it: black screen. I tried with 2 differents 512Gb : same black screen. Put a 256Gb : works fine!

Probably has to do with the type of cards

SDHC devices dont read SDUC for instance.

I don’t know which one the uConsole is but its atleast SDHC fully compatible, others outside that could face issues.

1 Like

I used 3 different SD cards, brand and size: still nothing.
Those cards works with various PI and with my DevTerm.

Last advice someone?
I guess there is a link to ask support questions after that. :man_shrugging:

My uConsole arrived yesterday, and having a similar experience:

  • CM4 module and microSD card that shipped. Have not tried re-flashing or an alternate microSD card
  • CM4 module is CM4104000, which seems to have no eMMC. No 4G card (just the blank card for speakers)
  • after holding power button, green light on power button comes on. after a few seconds screen comes on (“backlight” on, screen all on). Over 10 seconds or so screen resets, “backlight” on but all black)
  • after some time the power button is green+yellow. maybe that indicates charging? left it a long time and now solid-green and blinking yellow, screen on but no display
  • have tried combinations of batteries and USB-C chargers
  • have not tried HDMI

Try run on without audio module

I haven’t tried removing the audio module with the CM4 yet. I did try re-flashing the downloaded CM4 image to a different high-quality known-good microSD card, and behavior was the same as the included microSD.

However, I did also order the R01 module (riscv), and I was able to boot up with that after flashing the R01 image to the separate known-good microSD. And was able to get on the internet via WiFi! So hardware all seems to be working!

This happened to me, and it was because my CM4 module wasn’t fully seated on its carrier board. I had not worked with the CM4s before, so I was too gentle when trying to mate them - there is a bit of a click when it’s seated properly. I removed the SODIMM carrier board and more carefully mated the CM4 to it, receiving a little click when I finally secured it right. Then I mounted the carrier board back into the slot and booted up again - voila! Hopefully this will fix it for you, too.

If you’re not a CM4 then it’s still worth double-checking that everything is fully seated and secured! The display ribbon cable should go all the way into the slot before you click it shut - you should see no exposed copper fingers when the latch is clicked down.

1 Like

Professional life has been hard lately but I finally had time ton investigate once more.
I don’t have a proper solution, but after re-assembling my uConsole several times, at one point it booted :man_shrugging:
I was especially looking at screen connector but CM4 need also to click clearly on th adapter board, and this adapter itself needs to be really plugged strongly.

Just got mine the other day and had this same issue. Turns out the SODIMM wasn’t fully in the slot, it still had pins visible, and it looked a little crooked. Turns out that you can partially insert the board and still have it click into place.
After that, the CM4 module was a little crooked as well, looking at it from the side, maybe partially due to the thermal pad being a little crooked. A little massaging solved that issue.

With both of those issues solved, I finally got it to boot. With just one of them solved, the screen backlight would come on, but nothing else, which was both encouraging and scary, since I didn’t know if partially inserted pins would potentially brick the whole thing or not.

I got mine a few days ago! i switch from the emmc, i was thinking it was that the emmc wasnt working, then i got the one without emmc! still nothing on the screen i see a little power blip to the screen! but it dosnt actually power on i see you guys talking a bout a better SD card that might be the issue! i havent tried. but the uconsole seems to be working i out put hdmi and i see it on the screen but not on the Uconsole i reseated all the modules in the console and discontected everything and reconnected it! but no screen i see the green light yea i need a little help i guess im doing something wrong

bnewbold, I also own a R01. How did you connect to your wifi? I am assuming you were using terminal commands. Thanks