Brand new uconsole no picture on lcd

Hello folks.

Just put together my uconsole. I’m having trouble getting picture to the lcd. These are things I’ve tried.

  1. Reseated the lcd ribbon cable
  2. Completely dissembled everything and reseated core module, cm4, cellular module.
  3. Flashed different sd/os image.
  4. Tried just powering it up with usb-c.
  5. Powering it up without cm4, and lte module.
  6. Just powering it on and waiting a while.

I plugged in a mini hdmi and I was able to receive picture to external monitor but it doesn’t fully boot up. Also in the being of loading it does say SD card not detected. Then it’ll get to networking and sort of repeat everything. Not sure what’s going on here. Just figured I’d reach out here before contacting clockworkpi support.

Same issue here. Backlight comes up for <1sec and then nothing. Got my uConsole today.

If you hold the device at a slight angle while powered on, you should be able to see a green led glowing around the port inside while looking through the HDMI or Audio opening in the case like you can see in the picture. I was also having issues getting my A06 going after assembly.
I also discovered the button push timing was important.
Hold 3 seconds to power on
Hold 12 seconds to hard shutdown (will see green led go dark)

You have any luck? I haven’t had much time to fool with it but I flashed another SD card this evening without success. Mine also flickers for a split second upon pressing power but that’s it. Starting to suspect I got a lemon. :expressionless:

are you using batteries? or directly to power using usb-c?
If directly using usb-c, try a different power supply, as it may be slightly under powered.

Yeah I tried a few different power supplies, one being my steam decks . I think the issue is my CM4 has 8gb emmc and it’s trying to boot from it. I forgot that it won’t boot from SD because of this reason.

Hi, so is it the emmc on the cm4 that caused this?

I’m getting same issue, screen only flickerrd but nothing displayed afterwards, also seeing card not detected when plugin external monitor,

and my cm4 also has emmc…

Can confirm pls if this is the case? Sadly I don’t have another cm4

I’m 90% sure that’s the issue. The problem is the cm4 is trying to boot from eMMc and there’s nothing on it. I’m confident once my CM4 lite arrives it’ll boot up no problem. I’ll report back with that confirmation when I receive it. If you didn’t want to go though the hassle of buying another one you could buy the I/O board and flash the eMMC but then you’re limited in terms of space

1 Like

Thanks! I’m getting another cm4 without emmc. Just so happened Seeed Studio has them in stock :blush: will try it out once it arrives & update here too

SOLVED.: Can confirm this is the issue. For anyone who is dealing with this make sure your CM4 in the lite version or flash the eMMC with a I/O board.

Yup, and don’t worry if you don’t have a 4G card, it’s not required. It if you have a 4G model, it will run fine even if the 4G card slot is empty. ~ Cheers! :slight_smile:

Emmc version will work, if you have a way to flash it outside the uconsole. The mmc slot won’t work though.