Printer Troubleshooting on R-01

Got some paper for the printer and tried printing a test page via CUPS, and got a line and little else (no paper feed).

Wanted to remove some variables so I tried the echo command but nothing happened.

I found this post which mentions running the devterm_thermal_printer.elf for some diagnostics, and the results of this don’t look good:

cpi@devterm-R01:~$ sudo /usr/local/bin/devterm_thermal_printer.elf 
Error! ADC File cannot be opened
Error! ADC File cannot be opened
Error! ADC File cannot be opened
Error! ADC File cannot be opened
Error! ADC File cannot be opened
Error! ADC File cannot be opened
Segmentation fault

Watching the journal, I see a lot of lines like this before the segfault:

spi_set_clk()520 - [spi1] set spi clock failed, use clk:10000000

Not sure where to go from here, but any suggestions are appreciated!

1 Like

After additional testing I found that the printer will work after a restart to print text directly from the terminal (using echo), but when I try to print a .png file using lp or print from an application like Abiword, the printer makes a few noises and then the service fails.

If I restart the service, it will print a few more lines (of nonsense) and then the service will fail again.

I’m not sure why it’s failing. The only thing I see in the log is that spi_set_clk... line posted above. I also notice the CPU is pegged while this is happening so maybe the service is just crashing because the system is overloaded?

1 Like

I’ve just started playing more with the printer and I’ve observed the same issue as you where things fall over if I push an image at the device. Bookmarking this to come back shortly…

sudo apt update
sudo apt install devterm-thermal-printer devterm-thermal-printer-cups
sudo reboot

upgrade devterm-thermal-printer to 0.38

bug has been fixed

Acknowledged, thank you for this change - the new version seems to be able to accept text and image prints without breaking.

Now looking into how to manage text scaling better… using lp to print text files directly means the text is pretty large by default, but I think the control codes should enable this to be more flexible. I might try the kernel driver version sometime soon.