Shaders on Retroarch? It is possible?

retroarch

#1

Hello everyone!

I’m looking into options on improving how Gameboy games look on the GameShell. I’m currently using 0.3 with the Lima driver and the Gambatte core.

I stumbled upon this:

I’ve tried loading a Gameboy game and opening the quick menu following this guide with no luck.

Thank you! :slight_smile:


#2

Hi -

Since shaders use GPU calls, my guess is that this won’t be possible at the moment in Clockwork - of course it could be possible to run the whole lot in software emulation, but it will be very slow

Thread here

A link to OpenGL ES overview here


#3

I already tried this and it’s veeeery sloooow ^^


#4

Thanks, that’s what I imagined!

Related question: Do you know a way to make Gameboy games look sharper?

Non-integer scaling is not an option because pixels look wrong.

Thanks!


#5

Il also tried with some overlay but it’s the same deal…


#6

Build retroarch from source and then set the video filter to normal2x. The result is sharp pixels instead of blurry pixels without changing the look.
See here:


#7

Thank you Pixelpunker! This is exactly what I was looking for. Funny thing is I compiled and installed it with no issues, only to get it display a single frame on Gambatte… to then a frozen screen forever.

Sorry if this is asking for too much help… but I already tried a dozen of things, including:

  • Deleting all previously downloaded cores.
  • Deleting the retroarch configuration folder.
  • Pulling an snapshot of 1.7.3 and compiling/installing again, just in case the latest version was troublesome.
  • Tried no configuration override for Gambatte.
  • Checking the newly downloaded cores are actually from the “neon” source.

What’s really strange to me:

  • The sdl2 vídeo driver just hangs retroarch to death, even when launching it solo from the main menu. Black screen. Nothing. Got to kill the process.
  • Using gl at least launches it. I can fully interact with the menu, but that’s it. Retroarch still freezes when attempting to load a game with the Gambatte core.
  • This is exactly the opposite of what happened with the retroarch bundled in 0.3 in which gl would not work at all (!!).

I don’t know what to do!
Thanks for your help!

PS: That preciously rendered frame was perfect, totally worth it so I can play it like that.


#8

Make sure main video driver is set to Lima.
Don‘t launch the core from the retroarch menu. Create a launcher shortcut with the gambatta core by copying and modifying action.config
From time to time it will still freeze. Reset your gameshell and try again.


#9

I ended up flashing 0.3 all over again. It works now! Thank you! :smiley: