Review of recently recieved A04

I have finally recieved my A04 after purchasing it in March 2021. I have succesfully assembled the unit, and wish to provide some notes. This is what I wrote as I was assembling the unit:

1/13/2021: First assembled. Antenna wire was too stiff so mounted on plastic in different configuration. Screen appeared screatched at time of unpackaging and part of mental grounding became bent at attempt to “snap” into 3D-Printed chasis. Frontplate also difficult to snap in correctly, but succesful. No screwdriver was provided for only two screws in entire kit (which are holding screws only). No parts missing, though I had confused parts B1-B4 until near final step. Parts C1 & C2 could have been better explained as I attempted at first to snap them on backwards and discovered they fit into each other easier when you snap them together rather than on the machine.

6:05PM PST First Power-on
6:06PM PST: First boot succesful
6:15PM PST: Sound test fails. Attempted to play YouTube (via proxy in Firefox, and no sound played.

NOTE: Mouse hard to navigate screen. Default sensitivity should be turned up.

6:16PM PST: After running apt-update during sound test in terminal, then running “Software Updater” in applications menu, system prompoted that an update of Ubuntu is avalible. I selected yes. Nothing decernable happened after. I did not check htop.
6:20PM PST: First shutdown.

I am thankful to have the device finally, and I am still charging the batteries prior to giving it a more through use. I am curious if I could get a replacement screen and antenna since the ones provided were defective. Screen still functions, it simply is covered with scratches and the antenna wire was upside down in the recommended configuration so I had to lay it down on plastic under the screen, and also under the battery pack.

I also would like troubleshooting for the integrated speakers, which I have checked to see are in the proper configuration, and perhaps a guidence on the frontplate which seems too small (or perhaps warpped) as it does not snap together evenly.


for the sound issue

1 Like

This fixed the audio issue, thank you. As for the frontplate, I was able (twice) to get it into the proper position, but that is very hard. I think that should be looked at in the .cad itself.

1 Like

On further inspection, the scratches on the screen do not affect the usability of the screen and are probably only on the plastic (which I have not removed). Is there a recommended software thread? I’ve already installed a lot of custom software into this, and would like to add to the list.

I was going to upload unboxing photos, but the site disallows more than one image per embedded post for “new users”

1 Like

1 Like

So far, I’ve installed a number of under-the-table personal revisions, including basic Paranoid Anon security such as ClamAV and rkhunter. It came with no rootkits. No CCP worry!

I have also installed tor, and the tor-browser. I installed a number of things through a software program called Pi Apps, which serves as an appstore for Pi products such as this one. I also installed (using Pi Apps) a version of the game Minecraft modded especially for Raspberry Pi. It ran well, but the specialty joystick buttons did not interact with it. This is probably a configuration issue.

I installed Retroarch using a forum guide, but it fails to run. I also installed calibre. What else I am going to install, I don’t know, but I found that the default software bundle looks very minimal. I also thought that it would have a setup wizard on the SD rather than boot straight into the system.

I plan to test the printer at a later time, due to a lack of thermal paper.

I also plan to install networking tools as I have purchased a USB 4G LTE modem for the device. I plan to enable it not only to use the mobile internet, but also make and recieve calls as well as SMS. I’m not sure the best software to do this, but I am well aware that it’s been done before in an easily-accesable way rather than through serial-modem commands in a terminal.

It appears to be correct that this ships with “modern” software, as it has SystemD, PulseAudio, and Wayland instead of X11. I think this is the fault of Armbian (the apparent base system considering the homepage of Firefox), and not the choice or fault of the designers. Still, these things can’t really be avoided without a lot of anal-retentive effort now-a-days.

Typing is still something I will have to get used to on the system. Using both standard position, and thumb-typing, I continue to have errors.

I think next I will install the custom firmware for the mouse, as it is very poor as a selector. I think that a future release with both a touchscreen as well as an improved selector touchpoint would be better.

1 Like

This is the scrot of screenfetch. I don’t know if it’s a wayland bug or if the system is really running this slow, but the first attempt at scrotting (which you can see in the terminal) got only the first few lines of the screenfetch (same if using && instead of ;).

I ran geekbench which I installed via Pi Apps. The device is only on battery power. The full benchmark is viewed below:

Unrelated, bluetooth is on by default at first-boot. If you are not using bluetooth, you are both needlessly draining your battery and setting yourself up for an attack vector. The bundled DE allows you to disable it right in the statusbar.

1 Like

That’s the Minecraft I was talking about. The screen actually looks like that on pressing esc, not another transition that scrot picked up

In the process of attempting to install SuperTux and SuperTuxKart, the system’s DE randomly crashed and went into TTY2, with the cursor oriented in a different direction. I then was able to login through the login manager (I had changed my password after entering a sudo -s shell. This probably caused a problem). After logging back in, only SuperTux 2 appears in the games list in the application menu. Rerunning the previous apt command (in a new sudo shell) shows /var/lib/dpkg/lock-frontend unable to be locked. This implies apt is still running as a background process. Sure enough, a few seconds later, SuperTuxKart appears in the list as well.

It runs incredibly slow and choppy, as well as incredibly loud. Pressing the volume button on the keyboard, with or without FN, and with or without other combinations, doesn’t seem to be aliased to anything.

SuperTuxKart doesn’t support this resolution, but I have made attempt to bring it as close to full-fitting as possible. It doesn’t appear to have the power needed for the basic 3D rendering. I wait a minute or so. Still no rendering, and only the pre-race start engine sounds play. After taking the scrot, the screen says “Ready!” and only one ding sounds. A second ding “Set!” after about 15 seconds. Finally, the third ring “Go!” after about 10 more seconds, and the racers are off behind a black screen.

It took a few seconds to close the game as well.

1 Like

Still no CCP tricks found!

1 Like

A more complete analysis will be posted tomorrow, but for now here’s one more screenshot showing SuperTux running well. Default joystick conf is not proper for it though.

1 Like

I was going to provide further review by configuring a USB 4G modem, and send/recieving SMS as well as phone calls, but it seems that the modem I purchased all those months ago was defective. However, I am continuing to set up the thing to provide screenshots for people to see as well as confiiguring it to access some remote terminals I have access to.

I thought PuTTY was a Windows application, but it comes bundled with the DE. I usually use the OpenSSH client bundled with most systems and not application suites for remote connections. However, since PuTTY seems to be the intended client however, I will take screenshots of that.

Here is PuTTY’s opening configuration page. I decided to connect to my OSMC box to begin with.

And here it is after connection.


Here are some screenshots of using PuTTY to connect to the SDF Public Access Unix Server. I created a guest account because my passwords are too long to manually type (or remember). I plan to move over my password store at a later time.

And making the PuTTY session fullscreen clearly shows an improvement on readability in the terminal.

I don’t know why both FileZilla and Midnight Commander are installed, but here are both connecting to under anonymous access.

I think you should pick one or the other for a future software release, as storage-space is a priority for portable equipment such as this.

Another note: The backplate sticker isn’t adheasive enough and part of it is falling off.


Here are the scratches mentioned previously

1 Like

Because I was confused at the software suite for Kiwikit, I installed the browser plugin into Firefox. I then spent a good amount of time downloading (on my main PC) the .zim files for three specific dumps. I moved them over directly using my SD card reader and also moved over some PDFs and epubs for Calibre to sort. Hopfully I can take images of reading ebooks and wiki-archives without tremendous difficulty (which is one of the reasons I purchased the device). These archives and books are of course very large (with the Wikipedia archive being 11.9G even though it is a stripped-down version), so already the 32GB SD card has gone down significantly (6298MB left). I think I might remove some later.

I had no epubs readily avalible, so I downloaded two randomly from a known provider of epubs. Most books I keep on my PC are PDFs.

As you can see, the Kwiki extention works fine in the firefox browser, but I may delete other files due to how much space this has taken.

Calibre imported the two ePubs I saved in ~/Documents fine

This is Calibre opening one of the ePUBs. The ePUB opens without issue. I made the reader fullscreen after this.

The ePUB being fullscreen.

I changed the display settings to this, but the touchpoint was nearly inoperable. This may be due to the custom firmware I flashed into it early on which improved the selector for standard display mode.


This is wonderfully comprehensive–thanks, and keep it going! :metal:

1 Like