The ClockworkPi V5 compared to the V4, corrected the power management power consumption issue

It seems that I have failed . I don’t have a 220k resistor. first paralleled a 300k resistor on r108, which was ineffective, and then replaced it with a 200k resistor, which was still ineffective

Another thing you need to check is if it was real “deep” suspend-to-ram or just s2idle. s2idle will not turn off USB even with the mod. The easiest way I know to check if it is “deep” suspend is to see if the CPU module still generates heat, or see if it still drains ~300mA+ current instead of ~100mA

Deep sleep uses very little current and generates almost no heat.

Try replacing R107 (10k) with a higher value instead.

In my understanding, increasing the value of r107 and decreasing the value of r108 are equivalent. Therefore, I used a variable resistor to replace r108 for testing.
When the resistance value is above 50k, the USB is always powered after shutdown.
When the value is below 50k, devterm cannot be turned on and the power is quickly cut off

When I did my work on the V4 main board in the DevTerm, I was using the CM3 module.

I also have v4 motherboard and cm3. it seems that this method is not suitable for me

Bummer, have you measured the voltages on SYS_3V3 and at the voltage divider point with the system shut down?

Mr. PKR asked me to replace r107 with a higher resistance value, but I dare not operate such small components, so I have not taken any action for the time being.
But there is one piece of information you mentioned that is very important, when I measure the voltage, the USB power supply will stop immediately. Later, I confirmed that as long as my hand touches one side of r108, it will also stop, which makes it impossible to measure the voltage here.

That is why I am surprised dropping that 100K to about 68K didn’t work. When I attempted to measure it, it also shut down. Those 0402 are really small, I just stuck an 0805 on one side sticking up and a tiny wire from the other side to tack it down. I didn’t remove the 0402 100K just added 200K in parallel and got it down to something in that range.

I do have a microscope to help with it though.

Did you test with a flashed microsd card inserted and with software shutdown? Shutting down via power button might not work properly. The Linux kernel configures the AXP (power management chip that the power button is connected to) upon bootup. When you remove power and the batteries, that configuration is lost.

yes , I tested with software shoutdown

Because the contact of the test voltage divider will cause the power to shut down, I tried to pre-solder the test wire for measurement today.
When the power is turned on, the voltage from SYS_3V3 to the voltage divider is 3V, and the voltage from the voltage divider to the ground is 3V. When the power is turned off, the voltage from SYS_3V3 to the voltage divider is 0.09V, and the voltage from the voltage divider to the ground is 0.9V.

replaced R107 (10k) to 30k, worked ok.