uConsole 4G Not working

I’ve read through the 4g wiki, but I’m seeing some of the things described there but not others:

  • I downloaded the system 1.3 image and loaded it into my new uConsole CM4+4G. (which is otherwise working perfectly)
  • I have a T-Mobile SIM card seated correctly in the slot
  • The 4G antenna appears to be installed correctly
  • The speakers (which connect through the 4g card) are working
  • I went to /usr/local/bin and ran the following (bold are commands I entered):

uconsole-4g-cm4 enable
Power on 4G module on uConsole cm4
use mmcli -L to see 4G modem or not

echo -en “AT+CUSBPIDSWITCH?\r\n” | sudo socat - /dev/ttyUSB2,crnl

mmcli -L
No modems were found

mmcli -m any | grep “primary port”
error: couldn’t find modem

echo -en “AT+COPS?\r\n” | sudo socat - /dev/ttyUSB3,crnl
+COPS: 0,0,“T-Mobile”,7

echo -en “AT+GMR\r\n” | sudo socat - /dev/ttyUSB2,crnl
+GMR: LE20B04SIM7600G22
(this is the same firmware version described on How to upgrade 4G extension firmware · clockworkpi/uConsole Wiki · GitHub)

I also don’t see any mention of the card or usb in sudo ifconfig (only eth0, lo, and wlan0).

Any help would be appreciated!

Jeffrey Baron

I suggest to upgrade the firmware once

follow the steps in the wiki :

the right id is 9011, 9011 will give you the usb0

which will automaticly connect the 4G celluar data network

I’m concerned because of this line in the instructions you linked to:

“Next, use sudo ./fastboot/bin/fastboot devices to ensure that the device is detected. It should display something like MDM9607 fastboot .
If there is no device information, the operation must be halted.”

I activated the modem using uconsole-4g-cm4 enable, but when I run sudo ./fastboot/bin/fastboot devices, I get no response. If I ignore the warning above and run ./flash.sh according to the instructions, it never gets past “< waiting for device >”.

From what I can see, although I seem to be able to enable the modem and send AT instructions to it, nothing appears to recognize that the modem is there.

Any ideas?

right after uconsole-4g-cm4 enable


sudo dmesg | tail 

can you see


something like this ?

Please try to restart the ModemManager:

sudo systemctl restart ModemManager

Or try further by issuing a reprobe request:

sudo mmcli -S

Hope this can help.

1 Like

Well, it would appear that patience & persistence pay off, because, after re-flashing the disk image and then immediately following the instructions exactly, I have a live 4G connection and the ID is 9011. Thanks for your help with this!