uConsole's screw is hard to tighten, am I doing something wrong or is there exists different size of screws in the package?

I am new to uConsole. :face_holding_back_tears: and I am also wondering how the screen ribbon cable can be unlocked. thank you

got mine yesterday, the same. one screw screwed the front plate…

Hi ! The screws are a little hard to screw, due to the black paint on it and the chassis. It’s normal, but you can screw - unscrew once or twice to “unblock” them. You can also see some paint scales leaving during the process. (normal too)
All screws have the same length.

Thank you, anyway, I have spent about 4 hours trying to switch in the screws, and can not tighten all of them which are in the back of the machine… maybe I should give up

Try screwing them thoroughly without the back plate, it may help. If the threads are a little hard, it will facilitate the assembly afterwards.
It’s worked for me.

thank you, I tried screw them directly without backplate installed, still not working. seems that the screws are larger than

On other projects I have seen same issue and the idea to run the screw in and out a few times is valid.
May want to get a dental or automotive pick (paperclip will work) and try gently cleaning the base of the hole. Paint could be packed in bottom.

1 Like