32GB SD A1 not bootable (fixed)

Tried to use a 32GB SD Card by SanDisk, showing the A1 logo.

I’ve tried various methods on linux to clone the existing working 16GB SanDisk card.

  • Cloning the partition and extending to 32GB.
  • Cloning the partition and not extending (remains 16GB).
  • Cloning the drive and not extending (leaving 16GB unallocated). eg. sudo dd if=/dev/sdf of=/dev/sdi bs=16M status=progress

None of these methods are producing a bootable disk.

And, I don’t get any boot messages on the screen to see where things are hanging up. So I can’t tell whether its a disk issue, a format issue, or a security (UUID) issue. Where are the preliminary console messages going?

I see the post related to GameShell, but is the DevTerm the same? I only see one partition on the original disk, so I guess not.

Any thoughts?

EDIT Another attempt. Tried this method.

sudo dd if=/dev/sdf of=/dev/sdi bs=4M status=progress
sudo growpart /dev/sdi 1
sudo resize2fs /dev/sdi1

EDIT Adding the sync commands to above fixes the issue. Simply “Eject”-ing the drive from the desktop seems insufficient. There must be a lot of unwritten cached data in the system.

Yes, needs moar conv=fsync for dd