clockworkpi

[A06] DevTerm can't connect to my Wi-Fi

Just got in one of the A06 kits. Got it assembled. It boots up and seems to work fine. First problem: I can’t seem to be able to connect to any of my Wi-Fis. They don’t even show up in the list of available Wi-Fis. I do pick up all sorts of Wi-Fi from my neighbours. But my router doesn’t show up in the list. If I set up my iPhone to do Internet sharing it won’t show up either, even with “Maximize Compatibility” enabled. I tried entering the data of the Wi-Fi manually but it failed to connect. Seems like there is some kind of compatibility issue at play here?

The Wifi I’m using is
Protocol: Wi-Fi 4 (802.11n)
Security: WPA2-Personal
Band: 2.4 GHz
Channel: 13

Any suggestions?

This is a wild guess here, but could you try another channel? <12 If it works then you will need to configure your region with iw reg set <country code>

Channels 13 and sometimes 12 are not even shown on most regions Best WiFi Channel to Use for 2.4 GHz

So probably the default region doen’t expose those channels.

1 Like

Hm, this could be related. I was able to connect to the iPhone briefly. I checked and it was while it was running on channel 6. I tried switching to Japanese region with iw reg set JP but there was no effect. I don’t even know if it worked. Is JP even the right code? How do I find out which region it’s currently set to? Would I see the results immediately or do I have to restart? Sadly the router has all sorts of settings but does not allow me to set the channel.

I also have to say this is the very fist device in my household that has any issue with the Wi-Fi. And I have devices from all sorts of regions.

You could do iw reg get to see information about the regulatory CRDA.

And yes JP is the right code and I was going to suggest it as its one of the few I know support channel 13.

Edit:
After a quick google search I found out that sudo raspi-config now offers a option Set wifi country under localization . From there you can set a locale that enables the channel 12 and 13.

Update: Still doesn’t work. I sometimes get to connect to the iPhone Wi-Fi if I get lucky and the iPhone decides to broadcast on channel 6. Otherwise, I have no internet which really hampers my ability to solve my other issues with the device.

I followed some of the threads posted here

$ sudo iw reg set JP

Will successfully set the region to Japan but this will have no result on the available networks. I tried restarting the wlan modue too with

$ sudo ifconfig wlan0 down
$ sudo ifconfig wlan0 up

But nothing changes.

When I do

$ sudo iwlist wlan0 channel

it actually already lists channels all the way to Channel 13 and even some higher ones. So I think this problem is slightly different from the above RPI3 thread.

I tried sudo raspi-config but that obviously doesn’t work because it’s not a Raspberry system. sudo armbian-config seems to be the equivalent but it doesn’t have the feature to set the wifi country anywhere.

Not sure that would work, the rPI3 does not use the same Wifi chip as the devterm.

That is unrelated to the wifi chipset, its an OS thing.

Yes and no.
The tool come with the OS, yes, what the tool can do it tied to the driver and the driver to the chip.

Not all Wifi driver have the same options.

Update: Problem still persists. In the meantime I got hold of a CM3+ LT module. Installed it instead of the A06 core. Flashed the Raspbian OS. In this configuration the DevTerm sees and connects to the network no problem. So this seems to be a A06-specific issue.

I specifically can’t seem to tether from my iPhone via wireless, but it can with bluetooth. However connecting to any normal wifi network is fine though. Also A06.

Interesting, just in case you should try to re-image the SD card for the A06.

I had no issue here with the A06, and as the Wifi module is on the CPI board, not the SoM, if is works with the CM3 it also should with the A06…

1 Like