[SOLVED] Wifi access point not visible


#1

TLDR; Change Router’s channel to a lower number, for example 1 instead of 13.

Sorry for creating a “solved” topic, but hopefully this will save someone a few hours of painful debugging.

After setting up my GS with Wifi I’ve found that it no longer had the AP in the list on the next day, turns out my router had “automatic channel selection” option turned on and looks like wicd or whatever is used for networking does not see the AP on higher channels, switching to channel 1 fixed it.


#2

Actually its a matter of country regulatory domain.

Most Wi-Fi certified devices default to regdomain 0, which means least common denominator settings, i.e., the device will not transmit at a power above the allowable power in any nation, nor will it use frequencies that are not permitted in any nation.

I believe thats the case with gameshell too, so it probably sees from channel 1 to 11 or 12 by default. If you live in a country where is not illegal to use channel 13 like Japan, you can set your regulatory domain with iw

iw reg set JP

If someone wants to know more in depth about CRDA: https://wireless.wiki.kernel.org/en/developers/Regulatory


#3

Thanks @Petrakis, all of my other devices seemed to work fine, but this is some good info!