Anyone have Genesis/MD emulator working

Anyone tell me how to get Sega genesis/md emulator working
And Ive seen this post

Picodrive (standalone and libretro core) Mega Drive emulator

already did that, didnt work. tried all genesis cores in retroarch didnt work.

The “genesis plus gx core” on retroarch believe to be working.

I had no problem getting the standalone PicoDrive to work. I just downloaded the released zip and put the files from that on my gameshell.
Then you only have to give the executable permissions (chmod +x) to the emulator and the sh file and you should be able to lauch it through the sh.

i dont know how to add permissions since it didnt say that in the post i just followed what it said in that post.for the standalone PicoDrive

As I said before, I tried installing picodrive and it doesnt work…

I did download the zip as well and i ran it in retro arch and it never worked on any games. I followed the guide perfectly for the standalone Picodrive.

All I get is white screen ., or black screen and have to hard reset and I followed that guide exactly as it says.

Also in the first post i said

Picodrive (standalone and libretro core) Mega Drive emulator

already did that, didnt work. tried all genesis cores in retroarch didnt work.

So if all youre going to say is "It worked for me " Then ur not really helping at all.

So i guess , ill reiterate what i said in the first post, which is , I tried picodrive, and it doesnt work.

If all you got from my post was “It worked for me” then you should maybe read again.

I also posted a more detailed description in the PicoDrive thread just now, maybe that helps.

In order to give a file executable permissions, you can either ssh into your GS, go to the directory of the emulator and type “chmod +x [filename]” (replace [filename] with the actual filename) or use something like Filezilla, where you can just right click on the file and set the file permissions (just check all the executable options).

Yes, But ive already got the emulator showing up in GS, and launching. It just freezes when it launches. so i think i havce permissions, already.

I think I have it almost working.
Ijust need the url for the so file for

LAUNCHER=retroarch -L

IDK What the SO URL is for v 1.92 anyone haev it

I NEED the url to the SO file for 1,92 to set up the sh file right.

Idk why i can find the tar,gz and zip and all taht crap but no the 1 so file that i need the url for

If it goes right back into the launcher after opening the emulator, then it may very well be an issue with the file permissions, so I’d suggest you try to change them.

Oh I just saw that I didn’t write a more detailed description in the PicoDrive thread, but the OhBoy thread, but the procedure is basically the same.

The SO file is in the github url of the picodrive release:

and you can follow the instruction in the as described (it will download the so extract it and place it in ~/.config/retroarch/cores/ directory):

libretro core

To install on GameShell (OS v0.2), ssh to it and issue:

curl -sL | tar -xvz --directory ~/.config/retroarch/cores/

I dont know. It seems like everythings set up right.

I got the SO uploaded myself and its getting farther than before, now its trying to set up the emulator for thr first time , but still just restarting. I did try chmod +x on the action.config

So ill try that but im not really expecting it to work

The chmod +x has to be performed on the standalone emulator. If you use RetroArch, you don’t have to do it.

I tried all the genesis cores in retroarch anyway i cant get it tow work in tehre with any core gens plux gx or any version of picodrive with any videodriver

yes i knew all that already but thanks

Must be an issue with the new OS or Lima drive or something ? IDK

I have been able to get all otehr emulators working , including installing new ones like PCSX rearmed, and ive added my own new launchers to the main menu, for other emulators, which work fine.

But genesis i cant get working.

Could anyone give a step by step guide, knowing that I can SSH into GH already and know how to set up emulators and sh files. Just give a basic guide so I know I have t he FOLDERS in the right places and the correct action.config if u could provide it would help. For the 1.92 picodrive version


I finally got gens plus gx working using this basic guide on the wiki

This action.config worked

LAUNCHER=retroarch -L

hmm so picodrive can replace sega genesis and sega cd right? i have a snatcher rom and i want to play this silent hill visual novel.