clockworkpi

At attempt at updating leaves device stuck in "loading" state

I just assembled my Gameshell. I tried updating it through settings, and it is now left stuck in “loading” state. It stayed like that for half an hour the first time. So I tried rebooting it. Same state. How do I fix this?

guess your os image is too old for updating from launcher’s menu
so maybe re-flash an os image ?

This is something I am trying to find time to fix and create a pull request back into the main repository for.
When you get stuck in the “Loading” screen, chances are the launcher actually threw an exception and crashed and nothing is actually “Loading”, it is just that the background is set to the “Loading” image so you are actually just looking at the background -_-

I have some test code for the launcher so when it crashes, it has an exit hook that sets the background to an image that shows that something happened. Like a gameshell that looks dead or something.

I have seen various reasons for the launcher crashing. When this happens after you update the launcher it is typically due to either not being able to load images or multiple of the same directory (if you renamed 10_Settings to 90_Settings, when you update it re-pulls 10_Settings, so it loads the code for the Settings UI twice causing the launcher to crash. This is how I found out about the issue).

I have also experienced launcher crashes when exiting applications, like retro-arch. I still have to find time to try and contribute to fixing this issue as well.

1 Like