GameShell stuck on loading screen after update

Hi! I know there’s already posts out there about this, and I read them, but I’m still having trouble (I’m new to pretty much anything more technical than basic coding). I just tried to download an update for my GameShell the other day just through the “update” section under Settings, but now it’s stuck on the loading screen. I tried turning it on and off manually, rebooting it through an ssh connection, and using git pull on both the launcher folder and the launchergo folder. It was able to update I think, but it’s still not getting past the loading screen. It goes to the loading screen, blacks out like it’s going to the main menu like normal, then is just the loading screen again. I’m not sure what else might work. Is there anything else I can try, or will I need to do some kind of factory reset? I did hear something about flashing/re-flashing the SD card, and something else about making sure that the launcher folder is in the apps folder, but I’m not sure what either of those might do.

1 Like

Ok, I got you! I had the same issue, saw your post. I sent in a ticket, but no response. Then, I just figured it out. This will wipe your roms. I rather it turn on than to be a dead brick while I figure out where my Linux machine is in order to save my games…

Issue: Go to settings, see update, update, and uh-oh, stuck in loading screen. Skip to *** for instructions on how to get to the SD card. I did something in addition that didn’t help, and my game shell didn’t turn on at all nor charge. Fret not, I finally figured out where that reset button is. It’s tiny, but it’s on the opposite end of the power side of the board (the hinge part). If you have no power because you did something, ***simply open the GS, pull out the 4 retainer white knobs to your work surface, put the + direction button aside, push the back of the GS where the main board module is and forward with care to the cable lines. This will expose enough room for you to see the SD card and that little reset button. Click the button. Insert your power micro-usb cable to see if it powers on. Push to click out the SD card - remember which way it faces.

So, here’s a Linux based installation: GameShell OS image files (v0.5) . It’s annoying because you find out that apt-get is Linux only, and that just requires more work if you don’t primarily use Linux.

If you have a regular laptop or desktop that runs Mac or Windows, just download the clockworkpi gameshell operating system:

Save it to your desktop or download folder. Make it easy.
You will need Etcher. This is an app. New users can only put 2 links… just type this into your favorite search engine etcher. The one I want to link says balena dot io slash etcher.
You will need an SD card reader. You may have an adapter. It works.
You will need to pay attention to your drives.
You will need to rebuild your game library with this method.

Link to use for the non-Linux method: Clockwork OS, Etcher

  1. Download the OS file
  2. Open your folder or file where you can see different drives.
    There’s your main one - DO NOT REWRITE OVER THIS.
    Then there’s the disks that pop up when you insert a disk/thumb drive/etc.
  3. Connect your SD card
    You may need an adapter or plug it straight into your laptop/desktop.
  4. NOTE/Remember the folder that just appeared in your group of drives.
    Eject then unplug if you forgot. Repeat step 1-2 until you are SURE.
  5. Open Etcher.
  6. Select the ‘image’ which is the OS file you downloaded in step 0.
  7. Target the ‘disk’ that will need to be flashed/reimaged.
  8. Confirm and wait. Make sure your computer device has battery - so keep it charged for now. It’s about a 10-15m wait time I think.

Reverse order of opening up and insert the SD card and close it back up.

It should reboot, it’s a bit slower, but the quality and aspect ratios have now improved! Too bad that your library is gone, but it boots up and you just rebuild your Roms.

Hi! Thank you so much for the help! I do have a few questions though:

Do you know if there’s a folder on the GameShell that holds things like save data for games/ROMs? I’m ok just restarting everything, but I’d prefer if I could find a way to just ssh everything over to my laptop while I’m reflashing the SD so I don’t lose progress.
And does this process also delete stuff that came pre-downloaded on the GameShell like Cave Story, or is it basically just like a factory reset?

It wipes it clean, then copies a default image just like it was before this setting>update>loading loop. It has nothing saved. It’s like a factory reset, but there’s a few caveats and pros.

The loading is weird? It’s not the same, but be patient. It’s just different in that there’s a bit more time between screens and it goes black for a bit on the wake-up boot/when you turn it on.

Upside is a game like 2048 is upscaled and the menu text seems to render better (shift + menu). My new one had this new OS loaded in. The old one had a smaller aspect ratio. Hence I prompted an update on the older one. I have not checked out the rest but all default games seem like they are there.

As far as saving load states and roms, I didn’t dig that far into it. The way I did my file transfers was via wifi to some filemanager on windows. It was drag and drop at that point and should work in reverse order. That bridge should be able to relay info back and forth… but since there’s no gui for the wifi to turn on and the wifi info, you might not be able to go this route.

With that said, I did see a directory on the SD card when I inserted it into my computer. I didn’t really explore what was on the SD card. I didn’t have time to bother with it.

Maybe make a backup of the SD card or use a new one instead, then research how to pull files off it onto your computer. Then later bring those roms and saved states to the new SD card in the proper folders.

From what I gleaned, it’s stuck in a loop because certain things were moved around. So, I think the folder trees for games may or may not have moved too.