After System update, keep shownig LOADING


#1

I did system update on the Settings.

After update, It shows LOADING… screen.

How can I fix this?

Please help me.


#2

same here, all infos are welcome.


#3

ssh into GS

cd apps/launcher

git pull


#4

If he doesnt have usb eth or wifi doesnt connect that would be hard


#5

yes
I hope the wicd still working


#6

Fortunately, Wifi is available !

I’ll try this.


#7

Nice! then pull the launcher files and should be fixed.


#8

mine doesn’t seem to be getting the wifi adress.


#9

So - wait, there’s an update that bricks some devices? How there’s no more posts about it? Am I missing something?


#10

so after a few reboots got the wifi up and running, did git pull, which update the launcher, but still get stuck with a “loading” screen.


#11

do

ls -l

and check if the owner is cpi of the launcher files and folders.

If its root change it with

chown cpi file

I had my launcher stuck because of a simple thing like that a couple of times


#12

image


#13

will check them all to find a culprit


#14

permission look good but sys.py has a directory permision which I think its weird, I dont have my cpi here to check, lets see if someone else can check that.

Did you add emulators to the launcher before updating it?

Edit: its a dir my bad, got confused by the .py


#15

the only thing I changed was, adding a Menu Icon for Pico-8 and for the SNES Emulator.


#16

I break very often my launcher (gets stuck on loading) by adding menu icons for the launcher.

Check those icons also


#17

removed those 2 options, and now it works


#18

Nice!

Check their owner, they might have been root instead of cpi. (when adding them again)


#19

it was cpi, that’s why i was surprised. also, the launcher worked fine till the last 2 updates.


#20

also experiencing some menu slowdowns here and there.