Help! Stuck into loading screen after upgrade

Hello Guys

I just started the latest upgrade of the gameshell and no it is stuck into a loading screen.
Can anyone help me to start the gameshell?
What can I do to fix it?

I guess you did not upgrade the os image ,right?

try to flash a v0.21 os image

So buying a new Gameshell and doing an update bricks it?

1 Like

I just pushed upgrade in main settings menu.
Now it it stuck in loading screen.
How do I fix this?

You should upgrade the clockworkOS to a newer version. To do that, download the 0.21 or 0.3 image from here: GameShell OS image files

To flash the image to your SD card, download Etcher from here:

Insert your SD card into your PC, start Etcher, select the downloaded image and the SD to flash it.
After flashing, insert SD back into your Gameshell and enjoy the boot :smiley:

If you use an SD card bigger than 8GB, you can use a script I made to expand the filesystem to the whole SD card. Infos on that can be found here: Expand File System
(I made it as easy as possible)

I hope that helps!

thanks hpcodecraft, it works

I just had the same thing happen to me and I figured out why (at least for me).

When you check for and run update, it will update the launcher. To do this, it runs several git commands to checkout the latest from

One of those git commands is “git reset --hard $1”

Now if you are like me and reorganized your Menu by changing the ##_ prefixes, this will restore all the originals while leaving your new ones. This BREAKS the launcher. I haven’t gone through all of the launcher code, but it probably gets confused by the duplicates. For example if after the update you have 10_Settings and 90_Settings the launcher sees them both as “Settings” and breaks.

After removing all the duplicates caused by the update, launcher worked again.

Another thing to note, is that permission also can screw with launcher. I created a folder with “sudo mkdir” causing it to have root:root ownership and this also broke launcher making it stuck at “Loading…”.

Git should NOT be used as an update mechanism, and in this case, can be destructive as any changes you make to your launcher menu layout can be nuked and cause all sorts of problems like this simply by “updating” the launcher.

1 Like

Did some more digging / testing, having multiple items with the same name (with different number prefixes) only appears to be an issue with python menu items such as settings, music player, tiny cloud etc.

I ended up writing a script that does the menu mods I want (renaming items, installing new stuff etc). That way I can upgrade the launcher and run the script again. It’s painful but still faster than doing everything manually again and again. I totally agree that git is not an optimal upgrade solution. And if it’s used, the scripts themselves should at least check the OS version and act accordingly. It’s a really bad user experience if you buy a new system and nuke it with the provided upgrade…

Hi peeps, a bit late to the game, I know. I assembled my Gameshell and it was running fine. After a day or two, I decided to update and experienced the same problem as @Gatchaman_Ken. Then I followed the tip of @hpcodecraft. And then something very strange happened. I tried to turn on the Gameshell again and it does not do anything. So I decided to charge it and saw the small orange light when I plugged it in. But still, after charging, the Gameshell seems dead…What could have gone wrong? Thanks for the imput in advance!

Have you tried to flash another SD card with the OS and see if it works?

1 Like

@Joao_Manoel Has the right idea here.

Be careful with following instructions that are over a year old. They can very likely break things if they’re out of date. Perhaps make a back up of your image before trying anything you’re not sure of.

Sorry for the late reply, this solved the problem, many thanks!!