clockworkpi

Booting to "Happy Hacking" Screen after stopping in the middle of copying ISO?

Hi, It seems when copying large files like PS1 isos, sometimes there is issues and it messes up, i only get a filepart copied. Then I cant boot into the GS . I have to SSH in, deleted the incompete copied ISO , then it suddenly fixed it self and booted again.

But the ISOs i was copying should have copied fine, I dont know why it keeps screwing up. ITs done this twice now. Screwed up the copoying of the PS1 iso and left me witha filepart file. Then i only boot to the CPI happy hacking screen until deleteing the file

Actually, This started happening after I flashed the OS. So maybe im just out of space, So does this mean my 32g SD card was formatted wrong and its only giving me 3 gigs or something?? IDK, I just flashed the image as the guide said, i didnt do any special disk expanding operations?? IDK…

EDIT: okay I realize its only an 16 gig card, and I have access to about 7 or 8 gigs. So its just running out of space.

I guess thats all u get , IDK? I dont need a whole lot more, but did i originally have access to the other 8?

You have to expand filesystem to use your entire card.
Go into settings and look at Strorage to see if your entire card is used.
If not do this:

cd /etc/init.d
sudo wget https://gist.githubusercontent.com/cuu/b11109f2197cd482fe8d2c61b8d409c6/raw/672971991633283eaf8cdc0263a99472371b508d/expand_rootfs
sudo chmod +x expand_rootfs
sudo systemctl enable expand_rootfs
sudo reboot
1 Like

Okay i’ll try that… gulp

edit: i think it worked, idk, was afraid i might have to flash the OS again. But now i have 14.5GB so i can fit alot more PS1 isos on… thanks for the help, that made it really simple. i thought i might have to use ubuntu or something .

Good! Glad it helped you.