Can't get games to work

Managed to build the whole thing totally fine, but I can’t put any games on it. I can connect to my computer (Mac) through Tiny Cloud, but 99% of ROMS I try to copy over don’t work. I’ve tried GBA games, SNES, NES, nothing. I’ve tried them as .zip files, or as their unzipped files (.gba, .smc, etc.) They all just time out and give up, or they do copy over and I can’t see them on the Gameshell. I have gotten one or two games to work, but here’s what happens as soon as I boot it up: I hit run, it goes to a loading screen, then the screen goes black and it just boots back to the main menu. I’m at my wit’s end, I cannot figure out this thing.

Same problem here. Followed the instructions mentioned on this forum. Finally I see my .SMC files but they don’t start.

Have you tried running them from the RetroArch menu instead of the Launcher menu?

This means opening RetroArch through the launcher icon, loading a Core then navigating to the game folder and launch it from there.

This is an important step in troubleshooting because it eliminates some things from the process. If this works, the problem is with your launcher configuration.

Ok, thnx. Also in RetroArch I can’t load a SNES Rom.
Seems to be a problem with the launcher then.
Got this message:

You are not editing a file, but typing it in the command line.

You missed the step of opening the file where to put theses lines