Can't ssh to GameShell

network
ssh

#1

I just assembled the GameShell and have wifi connectivity. I was able to update the Launcher to 1.24 so accessing the internet is fine.

I then tried connecting to it over the LAN wifi using the “Tiny cloud” IP. I can see the GameShell from the router, I can ping the IP, but I can’t ssh to it. I get to the password prompt, enter “cpi” and the connection just hangs. I have to kill the terminal.

I tried from both Linux and PuTTY on Windows. No luck.

I was able to see the CLOCKWORKPI on the Windows network from Window 10 and could access the games/music folder as well. So that proves there is at least some way to get at the GameShell over the local wifi connection.

Any suggestions on how to get ssh working to the GameShell? It’s very puzzling, as I have many SBCs including Raspberry Pi, Parallella, PocketCHIP and I can ssh to any other those machines. What is so different about the connectivity to the GameShell?

Any help is appreciated.


#2

I was having issues from my PC, too, then I switched to using AndFTP from my Android Phone, and I’ve been able to connect to the GameShell no problem. All I do is transfer files from my phone to the GameShell and it works like a charm. Maybe you could try connecting from a device like I did?


#3

Thanks, but I’m not having a problem moving files back and forth to the GameShell. I can see the CLOCKWORKPI device on the Windows network and can access the /games and /music directories.

What I need to do is have ssh access to the GameShell, and that’s where I’m stuck. I can ping the IP on the local LAN and ssh does prompt for the password, so it’s at least trying to establish a connection. But then it just hangs. I tried from both Linux and Windows ssh clients with no luck.


#4

Ok, so this is interesting…

I set up a wifi access point on my phone (tethered to my cellular connection). I then connect a computer and the GameShell to this access point. I can now ssh to the GameShell without issues.

So it seems the ssh problem is due to my router or in the way I’ve configured my home wifi. I wish I could figure this out as it’s very inconvenient to have to tether to my cell.

I guess I could also go the USB ethernet route.


#5

That reminds me when I got my gameshell I had similar issue, the ssh hung up. It was a matter of poor wifi conection with the router. Things got better when I disabled the power save (It went form unusable to usable) How to disable wifi power save to prevent disconnects

P.S. Thats an old post and currently the power save option is added to the launcher (if you have it updated)

Also I recommend using the USB to Ethernet because its amazing compared to the wifi.


#6

Thank you, I’ll try that.

Where is the power save option in the Launcher? I am on version 1.24 and did not see it. Do you mean the power profiles? I’m using the server profile but still hang with ssh.


#7

No luck using the powersave_off script. I’ll have to use my cell as an access point.


#8

What about the usb to ethernet?


#9

I didn’t try that yet and probably won’t at this point since I’m using HDMI out to get the full desktop. From there, it’s like any other Debian machine with internet access. In particular, I can develop using the native toolchain there and have no need for ssh anymore.

I do believe it is the poor wifi signal as the root cause. My cell access point gives me about 95% signal strength while my router wifi is a paltry 40%.


#10

I found another workaround to avoid tethering off my cell. If you’ve got a Windows 10 machine just set up a mobile wifi hotspot. From settings “Mobile hotspot”–>“Share internet connection”.

This allows me to connect the GameShell and another PC on the newly created wifi hotspot and access the GameShell via ssh.

I don’t know why this works with the “virtual router” and not my physical router, but I’ve got yet another option over wifi.