Connect directly to GameShell (without router)

wifi

#1

Is it possible to use the Game she’ll to create a network and connect directly to it without needing a wifi router?

It would be great to use without anything else. This way we could connect to our device on the go without needing any other device. For example, I could connect to the GS using my Android while on the train. I do it now with tethering but will soon be soon travelling in another country without 3G so tethering won’t be available.

The GoPro is an example of this sort of connection, for lack of better examples or explanation, if I didn’t make myself clear :slight_smile:

Thanks all!


#2

When u connect with USB You can do

ssh cpi@clockworkpi.local


#3

How can I connect to the GS using Linux?

lsblk does not show the device, but it is charging through USB.


#4

I’m not sure but i think this should work:

Connecting to the Pi Zero with USB and SSH

To connect to the Raspberry Pi Zero over USB you’ll need Bonjour or similar installed on your host computer. I’m using a Mac so I was fortunate enough to already be in the clear. For Windows you should be fine installing iTunes or QuickTime and for Linux the Avahi Daemon. Many Linux distributions should have it already installed.

Should work the same way for the clockworkpi.


#5

Before using Avahi the GS itself should first be recognized as a USB device, right?

How do people in Windows see if the GS (hardware) is connected through USB?


#6

Not that i know, as far as i know its just a matter of waiting until the GS in fully booted. Then You can connect with ssh.


#7

This would be very useful!

Still waiting on mine (UK based, orders all been delayed in customs), should arrive this week, I’ll check and confirm!


#8

In addition to my earlier post, Windows nerds putty or simulair program to connect with clockworkpi.local. Mac and Linux should be able to connect using terminal


#9

Yes it is possible, you have to use updated kernel available on github and make some file changes to enable usb to ethernet

Thats to connect by cable with the device, as for wireless

You can set your cpi as an access point (or your other device) and create a network


#10

Thanx. Replacing the uImage on the GameShell SD card enabled my Linux to detect the hardware though USB:

$ lsusb
Bus 001 Device 005: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget

I am still stuggeling with the software side though, using Avahi on my host and/or USB Ethernet on my GameShell.

Not sure which steps are mandatory.


#11

https://github.com/clockworkpi/USB-Ethernet/blob/master/README.md all those steps are mandatory for usb to eth


#12

Does the GameShell have its own network range (192.168.10.x) or do I have to use my own home network range (192.168.2.x)?


#13

The usb is a network itself so it has (192.168.10.x) or whatever you set it up

So if you do ifconfig you should see a usb network device, and that network is your gameshell network


#14

Thanks. That’s what I did wrong.

I think this is it, so it is a question of time for me to get it working:

$ ip address
3: enp3s0f0u5i1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 62:e1:87:e5:58:77 brd ff:ff:ff:ff:ff:ff

I will try it later.


#15

Well. It works now! The steps heavily depend on the network manager you use.

I use netctl as a network manager on Arch Linux. I am probably the only one on this forum who does. :slight_smile:

  1. I followed your mentioned mandatory steps.
  2. I connected the GameShell through USB.
  3. I made a profile /etc/netctl/enp3s0f0u5:
Description='GameShell'
Interface=enp3s0f0u5
Connection=ethernet
IP=dhcp
  1. I brought up the profile.
sudo netctl start enp3s0f0u5
  1. I connected directly to its static address mentioned in your steps!
ssh cpi@192.168.10.1

Now I will configure the network profile to enable at boot and set a hostname for the ip.


#16

Nice! You could make a guide in a separate post in the tutorials category so people will find it easier


#17

I haven’t figured out how to get internet on the GameShell though USB yet.


#18

Follow the instructions in [USB-ETH] How to transfer files if you have unstable wifi

It has the instructions to share your Internet connection from Windows or MacOS.

LasVegas


#19

Hey folks, anyone successfully connected via SSH over USB with Windows?

At home I use OSX for working on my GameShell but it’d be nice to work on it over lunch at work.

Tried using putty to connect to clockworkpi.local but with no success, have installed Bonjour as per the Raspberry Pi Zero USB-SSH instructions but still unable to connect.


#20

A tutorial has been wriiten by @Petrakis how to set up the USB-ETH connection (also in windows). Perhaps you have not installed the driver for the board as mentioned there ? Does it show up on a com port in your device manager if you connect to it by USB ? Link to tutorial; [USB-ETH] How to transfer files if you have unstable wifi