clockworkpi

Custom GameShell image v0.4 with working standalone emulators

Hi guys, inspired by @Resbusmind custom GS image topic. I have tried and succeeded in making a custom GS image for v0.4.

This, again aimed at people who just want to flash the image, copy the ROM and play their game.

I have not changed anything from the Original V0.4 system files. However I removed all of the emulators that come with the stock image and put in the emulator for:

  • MegaDrive/Genesis
  • PlayStation
  • SNES
  • NES
  • GBA
  • RetroArch

I also “cleaned” the home screen a little bit by:

  • Put RetroArch in to Retro Games folder
  • Put all other system like Pico-8, Love2D ect into Indie Games
  • Put Reload UI, Music Player, Tiny Cloud etc… into Utils folder

So the Home screen now only have 5 icons: Settings, Retro Games, Indie Games, Utils and PowerOFF

The link to the image file:Download

My apology for the size of the image (4GB, i did try but can only reduce file size from 6.5GB to 4GB)

  1. How to install the image:

Download Etcher and use it to flash the image onto your Micro SD card

  1. How to expand the file system to match the size of your SD card:

You can try this suggested by Rebusmind :

Use PuTTY or a similar program to ssh into your GameShell and after logging in (username: cpi, password: cpi), type in the following: “bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/gameshell-setup/master/run.sh )”
Let it do its thing until it asks if you want to expand the file system to match the size of your SD card. Type “Y” and hit enter and after that, all the space of your SD card should be available.

Or you can use gparted to expand your partition.

3. How to copy game into the GS

If you are on Linux, you can copy game to each folder of each system, eg: “home/cpi/games/GBA” for GBA games. Other folders are for other system (MD for Mega Drive / Genesis, NES for … NES, PSX for PlayStation and SNES for the Super NES)

Or you can use Cybeduck, Putty, FileZilla etc… to ssh into your GameShell and put ROMs in each folder.

I have put in some ROM for each system so you can try right away after you flash the SD card.

4. How to change the icon for your folder / emulators, app:

There is a folder call skin (/home/cpi/launcher/skin)

Inside is the clone structure of your actual menu, if you want to change the icon for any emulator, shorcut or folder, just put an image in the correct place in this folder, reload UI and it will be changed.

I am a complete noob with Linux system and everything command line, I did not modify the core file systems, so I hope this will work as the stock v0.4 supposed to work. However if you encounter any problem please let me know and I will glad to help.

Hope this will help some of you in your early day with the Gameshell!

Cheers!

7 Likes

Nice work!!

Just wondering if you’ve modified the action files to read different rom formats etc. That’s a massive pain!

Also are bios files pre installed. Great if they are, but also a bit of a shady grey area. Anyway, depending on where you put your emulators and how you’ve set it up, bios location instructions could be useful!

With the home menu cleanup, keep in mind that if people do try and do a launcher update via the system menu, they could end not being able to boot up their systems. Likewise if people try and install community contributed skins. The best case scenario is that the icons just won’t work. Perhaps put a disclaimer mentioning something to that tube.

1 Like

Hi, i indeed pre-install the BIOS for gba and psx.

Will update the action file and tidy up a bit in the next upload.

I would recommend you remove the bios files again, as they are extracted directly from the respective consoles and therefore protected by copyright law. Of course it would be easier to have them pre-installed, but in this case I guess it can’t be helped.

2 Likes

thank you for the suggestion, I will make another and update this post.

after installing, I did the pico-8 install like I did before, it wont run

If you did it like you did before, it may have been the old days when you had to rename it to the previous version, ignoring the hash keys. (0.3)

The version of PICO-8 that is current, if using 0.4 should match up, meaning you can just install it normally without changing the file name.

Also depending on what has been altered re: button layout of the system, sometimes the confirmation button for installing PICO-8 can be switched.

its installed (did it before, but tried a new card with a modified loadout the OP posted, it installs, but when you run it comes back to the main menu

I had the same issue and got it working by copying the pico 8 menu item from inside the indie games menu folder to the main menu folder.

1 Like

Didn’t work for me now I have to menu selections for pico-8 that don’t work

Unfortunatly, this image does not work for me at all.
I get the clockwork pi flash screen at first, then a black screen from then on.
I have to do a hard reboot (pull the battery) to get it to shut off. I spent all afternoon (6 hours) working on this image and it still won’t work, so I have to go back to stock 0.4

Too bad, I was hoping this would save me time and trouble… but did the opposite.

Nice discovery! Again, this is why I’m always extremely hesitant to change around launcher icon layouts.

@dbcher 6 hours??? How many times did you burn the image?? I’m guessing you tried multiple cards too? Since some other people got it working, it’s really strange how some people’s don’t. I’ve always had luck using etcher for image writing to SD, as the OP also suggests. Did you use this as well?

Might be good for the sake of the OP to know these things, so they can make instructions abundantly clear given all variables. We are basically the beta testers haha!!

Yep, used 6 different cards… there 8gb ones would not burn at all as they came out ~48mb too small.
The 16 gb ones would burn (using etcher) with an extra 7.5gb unused space but then stuck at a black screen.
Oh, I also tried burning straight from the zip, but would get a failed error at the end, I extracted the image from the zip (16gb size) and that would burn, but not work.

The verification step took the longest.
I also tried expanding into the unallocated space (which took an hour with gparted) to see if that would help… it didn’t.

So yeah, 6 hours

my apologies for the problems :frowning:

1 Like

I’m going to test it myself. I’m fairly sure your image is fine, and it’s coming down to factors such as cards used, image burning process and user input. All things considered, besides the card, we have the same hardware and theoretically the same image; so everything should be replicable.

For now, possibly generate a MD5 checksum hash for users to verify the integrity of their files. That way we can at least isolate that aspect.

I’d also double check all of the apps that you moved to the Indi games folder, since they will possibly be directory sensitive. I’ll just do a quick run of all of them and report back.

1 Like

Thank you, I have just tried again with the image I uploaded and this is what i found:

  • I can flash it using Etcher on a 8GB card, providing I flash the Zip file, not unzip. However the device stuck at boot screen.
  • I flashed on 16GB card and then a 32GB card and it work normally, I have tested the standalone game as well as the Pico-8. Maybe because the buttons layout was set to YXBA in this image and that causes problem to other user?

However, I wonder should I delete this thread because it cause more problem to people rather than helping.

1 Like

well I have it burned to a 128 GB, everything but Pico-8 works, I have normal .4 burned to a 64GB and all works fine, not sure why Pico-8 refuses to boot, nice otherwise

1 Like

It’s certainly still useful information and education in the grand scheme of things. Ultimately it’s up to you! Perhaps putting a disclaimer stating the above would be a good addendum edit to the original post.

The problem is that some people may not read it; in which case, it’s up to them to ensure they do so. It’s hard fo sift through posts in a thread, which is why having the first post modified would be far better.

Better yet, perhaps someone here can diagnose the problem, and submit a fix. I will look into it as soon as I get home from work! :slight_smile: (edit: I lied. I was way to tired!)

1 Like

If it only would have a working UAE+ emulator, I would flash it immediately.

But: Great work and effort, really appreciate it!

1 Like

Perhaps you can ssh into the gs and chmod Pico-8 app?, that might be the reason why it would not execute