How to reinstall the OS

Hah, after updating the system via setting, the system shows me the loading screen all the time.

Well, after triggering something via SSH, I totally fucked up the system: after the CPI screen, there is only a black screen.

BTW, I cant locate the ‘launcher’.

So, maybe I should reinstall the system? How to do that via SSH? And, will I lose my pico-8 and saved data in retroarch?

your pico8 zip is in your PC right? if not
try to use winscp(use the cpi:cpi ssh account to login ) to copy the pico8 out of GS

but I remember that if you buy a pico8, you will have a download link in your email

so basicly , there is no need to worry about pico8,wont let you buy again

and the data in retroarch can be found and setup again because retroarch is opensource

here is the os image

use dd(linux) or win32 disk
to do the it ,flash the image into a TF card ,8G space Minimum

Another thing, the major issue I am having now is that I cant find the launcher.
So I tried “git clone”, still loading now. Is that a proper way to do it?

the launcher maybe in /home/cpi/apps/ since v0.2, we move the launcher out of /home/cpi/apps

and if you did the git clone
there is still a problem is bluetooth ,if your os image is v0.1 ,there is no bluetooth and it will cause the launcher fail to start

so the simple way is to reflash the tf card

Yeah, I saw these from another post.
Damn, the size of the OS is huge! Any tutorial of flashing the image? I am using a Mac.

But anyway, thanks mate

mac? that’s even easier than linux

just download the clockworkos_v0.21.img.bz2 and unzip it( take a little long time but not hard for mac)

and mac has dd ,but I have not used mac for many years so I can not remember whole command line would be

in linux
usually is

dd if=clockworkos_v0.21.img of=/dev/sdb bs=4096

the /dev/sdb is the device identification of the TF card, usually
I can get it by

dmesg | tail

when I plug the TF card in , the mac can do this ,too,but I can not remember how and which

For mac
I think command line is not the first choice
There must be a GUI tools can do the dd job

try disk manger

there is no big risk ,you just need to look out be carefully chose the disk you are gonna do ,do not choose the main HDD of mac os

Cheers. Will have a try.

BTW, why the ssh is very slow? Any reason? Something wrong with my Mac?

Not at all,you mac is fine

We did not realize the problem until one of us in this community find out that,

the linux system of GS has wif power save on by default and it casue the lower speed of WIFI (ssh)

and in the later os image, launcher has fixed it

Gotcha. BTW, should I move tha ‘launcher’ from /apps to the default direction?

move the launcher is not enough to fix your gs right now,

if you flashed the os image ,lanuncher will be in the new location

OK, so I have to download them now. Cheers mate. Hope next update is less troublesome…

A small question, mate: any recommendation for learning linux? It seems that I need to learn some Linux to make the full use of game shell.

On the Mac, command line is the easiest way. First enter diskutil list to find your memory card. Look for the card and its number on the right (diskX). Ignore the partition numbers, they will be wiped. Then unmount the card and proceed to copy to it:

diskutil umountDisk diskX
dd if=~/<path to folder>/clockworkos_v0.21.img of=/dev/rdiskX bs=4m

Replace the X with the disk number from the diskutil list command.

1 Like

Really well put together website.