DevTerm OS CM4 64bit image files

Official DevTerm CM4 64bit image files here:


Download: ==> Mirror #1 ==> Torrent
md5sum: 340ed7e4c01c3fa57ac5c5040f13e88f
Size: 1.3G

v0.1 latest release note:

· Based on the Raspberry Pi OS Debian 11 (bullseye) 64bit
· Linux Kernel v5.15
· Friendly LXDE desktop environment 
· Rechargeable battery energy management
· Standard CUPS thermal printer driver support

A BIG THANK YOU to the open source ecosystem and all supporters from around the world! :heart: :heart: :heart:


Is it possible to use the official raspberry pi os on DevTerm CM4 version?

1 Like

In principle it absolutely should be, since it’s literally a Pi board inside. I guess it would be most useful to know specifically what modifications have been made to this image for the DevTerm. Can the ClockworkPi team please list these changes?

althrough the wiki is based on armhf image
but the 64bit is pretty much as the same as armhf ,except all packages are made in 64bit


Per issue #45 I recommend that folks using this image edit /boot/config.txt and add


at the end of the file.

This enables the CM4 to use the external antenna that you’ve probably attached to the module!


Just to be clear, I can flash the Official DevTerm CM4 64bit onto the micro-sd and get going right?

The instructions in the wiki are there in case I want to re-create or modify what you guys have done?

1 Like

Yes, that’s right. If you want to get started right away, just download the image and flash it to an SD card.

1 Like

These download links do not work for me. Where can I get the image files? They used to be on the clockworkpi website but I can no longer find them.

ClockworkPi Disks Collection

There is now an updated image, with screen rotation at the kernel level.
(The disks collection has not been updated, as of this post.)


1 Like

just made a new os image for cm4 based from rpi-lite os image

using latest kernel same as uconsole image

start with xfce4 only, no lxde ,lightdm

integrated obsidian 1.3.7



Can the CPI team update the dl website to point to this image, currently, it’s pointing here:

Not sure how to inform them.

I’ve been thinking for a while that I’d like to get Debian Bookworm on my DevTerm. Now that the latest Raspberry Pi OS version is out and it’s based on Debian Bookworm, I’m looking forward to a Bookworm-based image! I think I’ll try following the instructions to build my own image as well.

Update: so far I haven’t really gotten it working! I can boot Raspberry OS lite with Clockwork’s build of the 5.15 kernel, but as soon as I install a graphical environment, it fails to boot, presumably because of kernel modules with the wrong version I actually have no idea why.

I also tried to patch and build my own 6.1 kernel based on the Raspberry Pi kernel at While I was able to manually apply the DevTerm patches and get it to build, I haven’t gotten my kernel to boot yet.

Update (2023-11-10): I actually have been having success running the stock RP OS Bookworm lite image with the DevTerm’s kernel and device trees. I just need to be careful to not allow kernel upgrades that will mess up my boot partition. I also tried:

  1. Moving the DevTerm kernel from kernel8.img to kernel-devterm-5.10.img, and modifying config.txt to point to that kernel image. That way, I can let Debian update its kernel without causing trouble. I haven’t gotten this to work, however. I can’t boot past the bootloader when I do this.
  2. My custom-patched 6.1 kernel. Still won’t boot though.

To debug both of these problems, I have an I/O board coming in the mail that I will use to flash the bootloader firmware and enable UART logging in the bootloader. enable_uart=true in config.txt works great for getting kernel logs over UART, but I need the bootloader logs as well since my kernel isn’t even booting yet.

Update (2023-11-17): After enabling UART logs, I was able to see that my patched 6.1 kernel does boot, it just doesn’t have working drivers for the screen or keyboard.

@xordspar0 I flashed your image with raspi image writer with ssh enabled. Could connect just fine. I don´t have enough time nor linux know how to achieve much by myself with the devterm, so i went back to official v2. Thank you for your effort, will keep watching this space ;).

Yup, it seems like just the DevTerm hardware-specific patches aren’t working in my testing, but the CM4 is still able to boot just fine. I’ll keep working on it.

1 Like

The download link for 0.3e is broken. Is there a mirror available?

this is the link from github that worked yesterday to “Save As” download

I don’t know if anyone else had these hurdles…

So, Recieved my DevTerm/adapter -no core yesterday and assembled… then spent a few hours trying every image available - .1 and .2 the battery managment didnt work… sudo apt update… sudo apt upgrade… no battery managment - battery at 0%… but it ran on battery power… soo…

trying .3e - this image is based of pi-lite…

for me… i was like… what does that mean? it means it is missing a few things…
This image had no GUI app for Bluetooth, and no GUI app for printers… (atleast when i installed it on my CM4)

go to setting>accessibility - turn on bounce keys at bottom (maximize any window you can so the scroll works right)

in terminal

sudo apt install bluez - manage adapters
sudo apt install bluez-utils -(this one said no build candidate… but wasnt needed in my case anyway… i guess?)
sudo apt install blueman - manage devices/gui
this added bluetooth gui (the icon in the status widget is temporary but it can be opened form settings)

sudo apt install system-config-printer
this re-added the “print settings” to my settings tab…

Then run

echo ‘KERNEL==“axp20x-battery”, ATTR{constant_charge_current_max}=“2200000”, ATTR{constant_charge_current}=“2000000”’ | sudo tee /etc/udev/rules.d/99-uconsole-charging.rules

to increase the charging speed so it doesn’t take all day to charge…

Then i sudo apt install geany

then sudo geany to open geany as admin…

Then add dtparam=ant2 to the bottom of /boot/config.txt - save

open /usr/local/bin/
scroll to the bottom and change max temp from 80 to 70 -save (first i did 65… but in normal use it would kick on and off on lap a bit too much…)


I don’t know about anyone else… but after doing that… i have bluetooth… wifi… printer… sleek enviroment… battery status… seemingly fully functional…