DevTerm OS CM4 image files

It’s entirely possible I’m wrong. Try it?

I really hope you are wrong.
Cause that was indeed my plan as well :smiling_face_with_tear:

I can confirm that I cannot read any SD card slotted into the DevTerm when it’s booted from the CM4 with eMMC.
I can read USB flash drives. This makes me suspect that you really do need an eMMC CM4.

Edit: Later comments on the thread / website indicate you can install the OS on a SD card if your CM4 is the Lite version without an eMMC. If the model of CM4 you have has an eMMC, you must use the eMMC as it cannot access the SD card.

1 Like

The website very much indicates the opposite and if a lite version doesn’t work with an SD card then there is a big problem. They literally recommend to use a CM4 lite.

  • For all CM4 EMMC versions, will NOT be able to use the clockworkPi mainboard v3.14 SD card function.
  • The CM4 Lite and the CM4 with 8GB EMMC or higher are recommended.
2 Likes

So a CM4 without eMMC will work with the SD slot, but a CM4 with eMMC will not. Makes sense! The eMMC seems faster so worth the inconvenience for me.

Confirmed that I now have a CM4 Lite (4Gb / Wifi / no eMMC) running with the 64-bit OS image on an SD card. It took me several attempts of installing and reseating the module, thinking it wasn’t working, taking it out and booting it on a separate carrier board, reflashing the SD image, etc. but I now have the basics working.

There are quite a few things broken in the ClockworkPi additions (e.g. fan), I’m working on identifying and maybe then fixing them at the moment.

2 Likes

I’d be curious how the performance of the CM4 without eMMC compares to the A06. (Also assuming that the hardware all eventually works with fixes, like fan and printer, etc. Does the HDMI out work as well?)

I don’t have figures, other than “wow, that’s SO much faster!”

3 Likes

HDMI is working. As soon as I find my printer I will test it… :-/

2 Likes

Printer works for me with the default system (although I had to set it as the “default” for lp to send data directly). I think the driver still needs work - same one as for the A and R cores - the default text size is pretty huge for a small roll of paper, and also I think CUPS has deprecated the type of driver that it implements - but it is functional.

I’ve now had all 3 USB ports recognise “things” (initially I had issues but I’ve since reseated everything).

I’m curious about the way that lshw differs between the R01 and CM4 cores. The device enumeration is very different, but I guess that could be a function of the RISC V kernel being a lot older.

I’ve also now had the game pad buttons work.

Need to write a “user guide” for folks trying the image as a daily driver…

3 Likes

Would to read some tips for sure!

(I plugged in an HMDI display and it worked as expected - I know someone was asking).

1 Like

A reply to the heat sink confusion, the clear plastic piece that was probably already fallen off the heat sink is the only thing you need to “peel off”.

The heat sink is copper on one side and black on the other side, no need to do anything other than try to get it to stick to the back case of the devterm copper side facing the Cm4 (the side will hang down and cover the fan pushing air away - very bad). Use tacton tape or thermal tape to tape the heat sink flat to the case, don’t worry about the cm4, it will touch as you close the case. Put the thermal paste on the copper side of the heat sink and tacton tape the uncovered areas - all of them.

Close the case and the cm4 will press into the paste/heat sink.

I’m guessing the idea is that the fan pushes air under the copper heat sink, passed the cm4 and away through other holes. I saw a few people asking for the “fan shim” before this came out that guided air to the A06 and this is essentially a hybrid shim/heat sink. I noticed that otherwise the cm4 would touch the case and they had to do something about it.

i install my CM4 lite modul with 4GB, copy the 32gb image in a SD Card but onyl a black screen

Mine isn’t working either, but working perfectly with the original A04 core. I’m gonna try and reseat everything, but things look rather solid. How did everyone get their CM4s running?

1 Like

there is a bug in the os image

Due to my neglect, both “devterm-thermal-printer” and “devterm-thermal-printer-cm4” coexisted in the system image of cm4, which is an incorrect approach. Although it seems that there are no usage problems, there are potential issues that exist.

here is the way to fix if you met any printing problems:

sudo apt update  
sudo apt remove devterm-thermal-printer devterm-thermal-printer-cm4 devterm-thermal-printer-cups -y
sudo dpkg --purge devterm-thermal-printer-cups

sudo apt install -y devterm-thermal-printer-cm4 devterm-thermal-printer-cups
sudo reboot

I need some help. I’ve tried flashing the OS multiple times, on different cards with belenaEtcher. I dont have the batteries yet, but I’m read in parts that this needs batteries for its first power on? I just about dis assembled and reassembled the entire terminal over 5 times to make sure that everything was seated in the right places. I’ve just powered it with a USB C directly. green light showers power, nothings. Before I flashed the original card, it would get to the point that the backlight powers on aboyt 5 mins later, then nothing… please help

I got a new CM4 and flashed the SD card. The console works fine but the HDMI output is not working. Any help?

Your other topic was for a uConsole, not a DevTerm? Or are you having issues with both?

1 Like

Having issues with both machines.
But just fixed this uConsole issue after re-assembling it + reflashing the SD card. I think the old firmware in the SD card was corrupted.

I don’t have my CM4 to play with yet annoyingly (soontm), what OS image version are you using?