Don't turn on after plugged in broken charger

Hi all!

I put my uConsole on charge, but looks like the charger was broken. Now I can not turn my console anymore: I disassembled it, and re-assambled again (without batteries), but it doesn’t help:

Now if I lug any charger in:

  • led stat green immediately
  • screen backlight turns on (this “black” colour)
  • turn on button doesn’t respond on click.
  • I unplugged everything from motherboard and it react the same way

I suppose than this broken charger just burnt smth inside, but I’m not sure what.

(I’m not an electrician, so, probably, I can’t check voltage and everything what is related to scheme of uConsole)

How do you think, if I order motherboard will it heal my console? Maybe that’s enough?

This has already happened to me, it was only the card of who was corrupted! Try formatting it to see.

Thanks for advice!

I’ve tried it recently, unfortunately it didn’t help (

Ho, I’m sorry for that. Do you have a tester ? It can be interesting to make some measures on the board…

Is your CM4 module one with Emmc by chance?

Unfortunately I don’t have a tester. Also, I’m not sure what to test here and what to do next) I’ll try to find experienced microelectronics engineer, but it is not an easy task for now :grimacing:

1 Like

I’m pretty sure that it is not. It was in bundle from Clockwork (uConsole+core), so it is lite version with 4gb on board if I’m not mistaken.

Ok that is good it does not have Emmc if that’s the case. If you remove the back and power it on there should be LEDs on the raspberry pi. Here is an excerpt from Pishop.ca

If a Pi fails to boot for some reason or has to shut down, in many cases an LED will be flashed a specific number of times to indicate what happened. The LED will blink for a number of long flashes (0 or more), then short flashes, to indicate the exact status. In most cases, the pattern will repeat after a 2-second gap.

Long flashes Short flashes Status
0 3 Generic failure to boot
0 4 start*.elf not found
0 7 Kernel image not found
0 8 SDRAM failure
0 9 Insufficient SDRAM
0 10 In HALT state
2 1 Partition not FAT
2 2 Failed to read from partition
2 3 Extended partition not FAT
2 4 File signature/hash mismatch - Pi 4
4 4 Unsupported board type
4 5 Fatal firmware error
4 6 Power failure type A
4 7 Power failure type B

so:

  • if the ACT LED blinks in a regular four blink pattern, it cannot find bootcode (start.elf).
  • if the ACT LED blinks in an irregular pattern, then booting has started.
  • If the ACT LED doesn’t blink, then the EEPROM code might be corrupted. Try again without anything connected to make sure.

This will eliminate the raspberry pi as the problem if you see no issues there. If you have a different micro sd card to try too that would be good. Microsd cards do not like voltage spikes.

1 Like

Thank you so much!!! It is pretty comprehensive guide!! :pray::pray: I’ll check it tomorrow in the office and return with the state.

You’re welcome. I would really stress that if you have another separate microsd card to test with that. Everything in your first post strongly pushes me toward your sd card getting fried. microsd cards can totally still appear to work but are still “bad” from a boot device perspective.

1 Like

I’ve tried several cards (100% works, I’ve just started one of them on regular Raspberry Pi 4B), and it doesn’t work on uConsole unfortunately :frowning:
Also I’m not sure how to check led pater, because of CM4 doesn’t have led it self, it has specific pins which should trigger leds on main board :thinking:
So I have couple options right now:

  • check RPI CM4 on other board (e.g. raspberry pi I/O board for CM4)
  • order new main board from Clockwork (I’ve already done this to be honest)
  • find some experience engineer

Probably easiest way is to buy I/O board just to be sure that CM is alive. I’ll do it somewhen in next month)

Thank you everybody for help!!!

1 Like