My new uConsole won't power on

Hey all - just built my uConsole and it won’t power on. No signs of life at all. Things I’ve tried…

  • Removed the LTE module, since someone else in this forum had a similar issue only when the LTE board was installed.
  • Reseated the CM4 module and the adapter board.
  • Confirmed the 18650’s are fully charged. Tried powering up with just the batteries.
  • Tried powering up without the batteries installed.
  • Tried powering off of several different power adapters, all known good and rated 2.5-3 amps at 5v.
  • Tried several different USB-C cables, all high quality / known good.
  • Tried the official RPi adapter since others have reported success with that particular adapter.
  • Reflashed the O/S
  • Tried a different / known good SD card.
  • Tried a bunch of different power button patterns. Holding longer, shorter, etc.
  • Tried just… waiting…
  • Tried the mini HDMI output to see if an external monitor would display anything - it doesn’t.

Here’s a pic, I don’t think anything looks off but maybe I’m missing something. Thanks for any help!

1 Like

Nothing looks out of place from what I can see (other than those super sketchy 18650s*). Your Pi is in the right orientation, battery board connectors look good, and you already tried 100% of the most common troubleshooting steps.

Best thing I can recommend is to check your voltages on the Pi with a multimeter if you can to see if it is getting any power when you try to power it on. Otherwise try flashing the OS to your known working flash card again using a different tool (Balena Etcher, Rufus, RaspberryPi Media Writer, DD, etc).

For my comment above about your batteries, the GTF (or more rarely GTP) branded 9900MAh batteries like yours I have tested usually only hold about 850-1200MAh. Trying your uConsole with another set of 18650s might not be a bad idea in case these ones cant handle the draw, but these sketchy cells do usually work so i kinda doubt this is your issue.

If nothing else works, email ClockWork. Their customer service is pretty great. They quickly sent me a replacement mobo for my GameShell when it was DOA with very few questions asked.

Adding an image of my uConsole just in case someone else notices something different.

1 Like

I spotted that 9,900 mAh also, I agree that most likely that is the problem. I had some that claimed 6,000 and were light as a feather. Putting them in a proper tester, they got about 650 mAh.


I don’t understand the certainty that the batteries are the problem? As I said above, I’ve tried powering without the batteries using high quality USB-C cables and adapters.

You hold down the power button to start it and not just give it a quick click, yeh?

1 Like

holding down the power button for a few seconds and a green LED should light up. regardless if you have HDMI connectors, batteries, or microSD card. That should save you from trying things that won’t work.

I suspect you tried everything and it’s time for you to reach out to support in order to get a replacement.


Yeah, as mentioned above I’ve tried every variation of hold down (quick, 1 second, 2 second, 3 seconds, 5 seconds, 10 seconds) I can think of.

We aren’t saying that the batteries are causing this issue (though i suppose it cant be ruled out conclusively without direct replacements to test against), we just mentioned that the batteries you have are known to be of very low capacity and quality. We only mentioned this so you are aware that these batteries may cause other issues in the future and not perform as you may have expected.

Think of it like this: you are in a parking lot and your car wont start. We are just letting you know that you also have a nail in your tire.

I was referring to aother post, apologies! Your post was detailed and appreciated.

The batteries are definitely garbage and will be upgraded, but I have a fairly high level of confidence that they’re not the issue given the complete and utter lack of any signs of life whatsoever, even when powered by USB-C and no batteries in place.

remove everything (including RPi & adapter board), keeping only the base board and battery board. maybe disconnect the LCD too. remove the batteries for a minute to reset everything. connect usb-c power if you wish. a long press of the power button should power on the board & green led. if no power, it could be one or more of the following:

  • button and/or supporting components is bad/damaged
  • AXP power management chip and/or supporting components is bad/damaged
  • there is a short on the board

also, try it again without batteries, just in case…


This was incredibly helpful, thanks! I didn’t even realize their was a power LED…

I disassembled everything as you suggested, pulled the batteries for a bit, and reseated. With a two-second hold of the power button, I received a green power LED.

I then removed the batteries and added the CM4 with adapter board. Added batteries, powered up, green LED! I waited a few minutes and I was presented with the desktop and was able to complete the setup. Score!

I powered down, removed the batteries, added in the LTE board, and tried powering up again. The LED just flickers briefly. If I remove the LTE board, it boots right up now.

So, I think it’s safe to say I have a bad LTE board. It looks like there have been a couple others in this forum with the same issue.

At least now I can narrow it down to a specific component and get a replacement. And I can get some use out of it while I wait.

Thanks for all the help!


Interesting, where is this green led located?

Besides the power button. If you use the white button, it will glow.

1 Like

Got it to work now, swapped out the black button with the white and can see it’s green when on, and orange when charging ~ thanks!

I have been having the same issues unfortunately. Only after 3 days of ownership.

9900mAh ???
replace your batteries。