UConsole won’t turn on

Assembled without issue. Just reflashed new firmware and tested the card. I don’t have a spare CM4 to test with, unfortunately. Batteries are tested and full charge. I just re-seated the CM4 adapter as a precaution but was fine.

Basically will not turn on at all: I see no signs of life, no lights, nothing.

Do you see any problems?

Edit: If I remove the 4G module entirely it will turn on. I’m guessing that module is a dud.

1 Like

Stupid question, but are you sure about the battery polarity? Hard to tell from your photo.

Also make sure that the connector for the battery is properly clipped, on the DevTerm it needed a bit of force for me to get it in fully.
From your photo they seems to not be inserted…


Hi, thank you for the quick reply. I edited the post with the most recent. I got it to turn on if I disconnect the 4G module entirely. Guessing something is wrong with that board for me, and will get in touch about warranty.

1 Like

Could it be that it contributes to power draw? Try with the power cable connected

1 Like

I’ve tried with a power cable unfortunately. I have a multimeter if you could point me to the right spots to test though.

1 Like

Unfortunately I haven´t received the uConsole yet to be able to provide test spots, better contact @AlexDuan in this case.


Same problem here but removing 4g module didn’t help…need a micro hdmi extension to test video output

Alex was quick to respond and is sending a replacement re the dud module.

if its not turning on, check battery and rpi adapter seating first. If you have a multimeter, check the battery voltage and polarity. Voltage should be around 4.2v. Also try usbc charging. Also check and reflash the SD card.

Hope it work!

That was the SD card. Formatting with camera and then back to balenaEtcher and that’s fine now.

1 Like

Another thing the adapter has very thing tape on it make sure you remove it can be missed.

Hi, I also just assembled uconsole 4G, when I pressed the power button, the screen flickered/flashed white, but went off again and never showed anything after that.

Tried with a known-working raspbian SD card from a desktop pi4, but same behavior, there was a flash/flicker on the screen, but no signs of life afterwards

I don’t have 4g sim card, is it required or is it optional?

Batteries are new, tried with usb c powered cable, same result.

Tried plugging micro hdmi but also nothing is ever displayed after a flash/flicker…

Any suggestions guys?

1 Like