clockworkpi

Gameboy and gameboy color emulator that works in OS v4?

The MGBA directory in the game’s section only goes to gba games, how can I play both?

did u mean you can not see the gbc roms in the MGBA list?

Well I can see them, but when I try to play them it boots me back to the home screen

@guu

mgba seems not work with gbc rom

maybe you can try to create a new menu item with this action.config in ssh

ROM=/home/cpi/games/MGBA
ROM_SO=/home/cpi/apps/emulators/gambatte_libretro.so
EXT=gb,gbc
LAUNCHER=retroarch -L
TITLE=GBC Roms
SO_URL=http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/gambatte_libretro.so.zip

mkdir ~/apps/Menu/20_Retro\ Games/31_GBC

1 Like

Can you confirm what GBC ROM you are trying to run?
Also, could you confirm whether or not any other emulators that depend on retroarch run?

I just tested The Legend of Zelda: Link’s Awakening DX, which specifically has features only available on the GBC hardware. I loaded up a save file at the point of the hidden GBC dungeon. It ran without consequence.

Confirming other colour capabilities, I also tested Kirby’s Dreamland 2, specifically using Super Gameboy compatibility. It loaded up the additional colours, borders and additional world select sound effects fine.

I was using MGBA on clockwork OS 0.4. I have also specified a GBA BIOS file. My guess is that this may be the culprit.

Otherwise, possibly your game file is corrupt, or not decompressed correctly.

1 Like

Alright this is what pops up, but sends me back to the home screen, but if I run the game through retroarch with the gambatte emulator, it runs perfectly

EDIT: got it working, just had to delete the previous gambatte emulator

So just confirming, for future people’s sake: did deleting the gambatte core from the retroarch core list fix being able to use mgba from within the Gameshell emulator list?
If so it sounds like there was something up with your core management in retroarch.
Core *.so files downloaded via clockwork OS don’t appear in the retroarch core list, so managing mgba from within retroarch is something you do once you’re running the core - an interesting dilemma when you can’t load the core to begin with!
But hey! Good to know you’ve got something working now.

Ha it’s funny! I was just playing this game the other day. If you enable retro achievements, it’s got a pretty good achievement list!
That said, it’s not a GBC game, but a GB classic black and white game. One of my first games I owned on my first game boy in fact, and in my opinion one of the best Castlevania games. :slight_smile:

1 Like

I think it’s because I downloaded it before, and forgot so with the action.config just downloaded the same emulator again so it caused it not to work, thats what I figured, and well it easily worked.

There are retro achievements?! That’s amazing.

The other two castlevania games gb are pretty bad

Re: retro achievements, it really gives a breath of fresh air to older games, and is one of the main reason I haven’t converted to just using standalone emulators.

Agreed re the other GB games being SHOCKING!!
If you’re a veteran of CV games, put in the password BLANK ORB BLANK ORB to activate hard mode. Also, play the Japanese version, (Dracula Densetsu II) if you want to use the FAR SUPERIOR boomerang/crucifix. The axe was absolutely USELESS!
(There’s only 3 bits of text to read; the prologue, the soleiyu interlude and the epilogue. You can look up a translation if you don’t read Japanese.)

Sounds great thank you, how can I enable the retro achievements?

This thread goes through the initial setup, ie making an account etc.

I tried to search for more step by step instructions but couldn’t find anything straight away. I’ll just sum it up quickly.

You’ll need go ssh into your Gameshell to add your username and password.

After you’ve gotten that, you can view the achievements setting in the main retroarch settings page. Activate it there.

To view the achievements list, use the hotkey to enter the retroarch menu, after loading your game. Then go to the quick menu. There should be an achievements menu item you can select.

1 Like

So many achievements for so many games, this is pretty awesome thank you

1 Like