Gameshell not turning on, i think the battery is dead

the first day i got my gameshell, i wass really exited, so i played it to death. but it run out of battery, i thought “i’ll just charge it.”, so i plugged it to the wall, and the next day. nothing happened, that was like 2 years ago. i still don’t know what happened, and how to fix it, so please help.

1 Like

i should have been more specific, but the problem is that it doesn’t turn on.
nothing is making it respond.

in that case i STILL think you need to provide more details… because you havent given us much to go on… here is another post that i think might be relevant… but may still be unrelated:

Here’s the complete story:
It was christmas, and i was exited as hell, i got the gameshell! I read the instructions, and put it toghether, we were going to grandma’s house to eat, like always, i thought “i don’t have time to put games here if we’re leaving, i’ll just play cave story until we come back.”, afterwards, we also went to grandpa’s house, and the gameshell ran out of battery, so i put it in my bag, and waited until we came back, when we did, i noticed there wasn’t a charger, or instructions on charging. so i grabbed my phone charger, i plugged it into an outlet, and the usb port on the console, and i went to sleep, the next day, i went to the gameshell, i tried to turn it on, and nothing. i tried a couple more times, i charged it with the outlet again, i charged it with the computer, and NOTHING! since then, the gameshell hasn’t turned on, no matter what i do

1 Like

If this doesnt help you, I’m not sure what else to advise… Maybe someone else wants to take a crack?

i tried with everything, i think my battery is defective, or something.


There’s a hidden reset button that might help. I had to use it once myself a long time ago, and it’s been mentioned a few times on the forums though I couldn’t find a post with a picture.

From my experience it seems like letting the battery discharge completely is a bad idea. Something gets confused and the reset button might have to be used even if the battery is fine and can charge. That’s all the more reason to mod the GameShell and put in a larger battery. The one it comes with is lightweight and small, but doesn’t last long on a charge. There are several posts around here discussing battery mods, and it mostly comes down to finding a compatible battery that fits inside the case (unless you want to modify the case too) and also the wires/connectors needed to hook it up.

I’d recommend using @javelinface 's custom OS, or one of the others instead of the official OS too. Out of the box the GameShell was functional, but not great. With a few tweaks like the battery and OS though, it can be made better. :slight_smile: