GameShell shuts off

It’s weird tho because it only happens now and again.

Once it boots into the OS… and I turn off Bluetooth (or kill GSNotify) it runs like a top until I turn it off myself

Edit: for instance I just started it up after 6 misfires and it fired up into the OS… everything is fine now. GSNotify works great (I turn off BT instead since I don’t use it)

like old gun

I’ll do more test

And to make life harder. It just shut down mid game… Bluetooth was off. :frowning: gonna try again killing GSNotify.

so last time for sure
your battery is ok ,right?

Yah. I mean I never had an issue I don’t have volt meters or anything to test… charged it yesterday. Connections are all good. Says it’s half full

Just plugged it in to see if any issues happen on hard power

I guess the bug is on gsnotify

sorry for that first
I’ll do a quick update of launcher very soon to fix that for u

1 Like

Could it be causing a system crash?

When does GSNotify actually “start”? If it loads before the splash screen, then I’d say it’s a possibility!

gsnotify is an app written by SDL2
so it started at xinit,just when you see the loading picture

I guess the splash screen you mean is the bootup bios picture,right?

Sometimes it would crash before bios. Sometimes it would say “loading” for half a second and shut off.

I have been plugged in since my last post and have had no issues… BT and GSNotify are running.
I hope this isn’t a short in my battery or something

Maybe being plugged in for long SSH sessions fried it? Should remove battery before doinghuge transfers lol

can not really know what’s really going on

I crashed 3 sdcards because of the power failure,like battery out

so I added a function to do a shutdown when the battery of GS is 3% lower

your case makes me reconsider canceling this function,and not sure if it is better

1 Like

well, whatever you come up with I can be the “guinea pig” to test it on hahah thanks so much for all your help.

thanks man ,I really appreciate it.

1 Like

If I gotta rebuild so be it. I’d rather help be part of the solution! I love the device to much to stop caring

1 Like

Maybe it is my battery…? I had BT off and killed gsnotify… unplugged from a full charge and it ended up just shutting down :frowning: I’ll have to get another battery to fully isolate the issue.

I’m gonna dry disabling the “Low Battery” script in the notification menu. BT is off. So far no crashing but it’s been on for only 5 minutes.

Crashed again, and then again as a started typing this.

Just gonna play plugged it since that seems to work. Not an issue right now - starting to really think it’s a power fault tho.

I recommend that you verify that your battery cable is well seated on both ends. A loose connection could be causing your issue…

1 Like

Just tried resetting the wires. Did every single one for good measure. Everything seems nice and snug, and the wires aren’t tampered with. Gonna see what happens now with my usual setup of BT turned off, wifi rescued, and GSNotify running a Low Battery script.

Will post results

15 minutes of gaming shows no errors. It was shutting down like crazy… have the wire wasn’t seated properly… seems like a weird thing to just randomly happen but here we are.
Will keep an open mind Incas anything else happens and as always, will report to you!

Thanks @lasvegas for the solution (seems like something I should have tried first but I honestly haven’t touched them since I set the device up so I didn’t think I would need to)

Thanks @guu for the hasty replies and the background work.

Low battery script won’t do a shutdown job

gsnotify-arm has the code inside it to check battery percent and do a shutdown job
(I’m so surprised that your sd card data is still complete after so many un-expected shutdown)

so I suggest you just delete gsnotify-arm from ~/launcher/
and also turn off BT( I think BT is ok ,impossible to crash the GS down) in case

you can use

sudo rfkill block 2

to block hci0 off ,hci0 is the bluetooth

Sorry for the post to an old thread.
Re: the notify, and shut down at 3% (which is a great idea to avoid SD card corruption, like on my GoPro), can a suspend state be invoked instead? Just so you have the option of plugging in power.

Just we’re not cross posting too much, I also posted a similar suggestion here, but thought it would be more pertainent as a safeguard feature.