clockworkpi

Will boot when plugged in/Won't boot on battery

Started having an issue with my GS this morning.

I was playing pretty extensively yesterday entirely on battery so I decided to charge overnight. Went to turn it on this morning and it booted up to the Penguin logo but shut down before the “CPI”/“Happy Hacking” screen. Figured it might have been a fluke so I tried it again with the same result.

Plugged it in to see if it would boot and it did! While plugged in, the charging light was not on, but it gave me an indicator that my battery was extremely low (despite overnight charge).

My skill level with his stuff is low so I searched the forums for similar issues. Followed all of the advice with rechecking/replugging wires, reset button, etc. none worked. Other feedback came back with slightly different problems won’t turn on at all, or main board issues. Mine seems to run fine when plugged in but won’t charge the battery.

I’ll take any and all help! Again, it was working wonderfully not 10 hours ago. Thanks!

Unfortunate, I will say that you should probably double check that the battery is seated correctly and the cable is seated correctly. I only recently constructed mine only to discover I didn’t seat the lightkey correctly so shoulder buttons didn’t light up.

Micro usb cables are also iffy, if you have another cable, check to see if it charges on that.

Thanks for the tips!

I did attempt to reseat the battery a couple times to no beneficial result. The micro USB cable I’m using does seem to be functioning properly as my GS only actually boots when plugged in.

I was able to reach out to the help email and they said it is something that needs to be resolved with a new main board. They were extremely friendly and are sending one soon!

Great! Hopefully all goes well in the end, there has been times when I have ran into issues with poor micro-usb cables with a raspberry pi that I have learned to be wary of them.